summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorChuanhong Guo <gch981213@gmail.com>2018-04-22 18:29:36 +0800
committerJohn Crispin <john@phrozen.org>2018-05-22 07:58:16 +0200
commita789c0f49159c618d990541c23e00630f7296ebc (patch)
tree48a5e471a8dadb55f70b917278f4f3972fb43d35 /target/linux/ar71xx/image
parent67a3cdcbb05559549985a189eabaf2df92559ed7 (diff)
downloadopenwrt-a789c0f49159c618d990541c23e00630f7296ebc.tar.gz
openwrt-a789c0f49159c618d990541c23e00630f7296ebc.tar.bz2
openwrt-a789c0f49159c618d990541c23e00630f7296ebc.zip
ar71xx: Add support for PISEN TS-D084
PISEN TS-D084 is an wireless router with a battery and integrated power supply based on Atheros AR9331. Specification: - 400/400/200 MHz (CPU/DDR/AHB) - 64 MB of RAM (DDR2) - 8 MB of FLASH (SPI NOR) - 1x 10/100 Mbps Ethernet - 1T1R 2.4 GHz (AR9331) - 1x USB 2.0 Flash instruction: The manufacturer are using exactly the same firmware header as TP-LINK TL-WR703N (including device ID!). Simply upload the factory firmware into WebUI and flashing is done. Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/generic.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/generic.mk b/target/linux/ar71xx/image/generic.mk
index 020e01f85a..bceeba0009 100644
--- a/target/linux/ar71xx/image/generic.mk
+++ b/target/linux/ar71xx/image/generic.mk
@@ -998,6 +998,17 @@ define Device/tellstick-znet-lite
endef
TARGET_DEVICES += tellstick-znet-lite
+define Device/ts-d084
+ $(Device/tplink-8mlzma)
+ DEVICE_TITLE := PISEN TS-D084
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2
+ BOARDNAME := TS-D084
+ DEVICE_PROFILE := TSD084
+ TPLINK_HWID := 0x07030101
+ CONSOLE := ttyATH0,115200
+endef
+TARGET_DEVICES += ts-d084
+
define Device/n5q
DEVICE_TITLE := ALFA Network N5Q
DEVICE_PACKAGES := rssileds -swconfig