summaryrefslogtreecommitdiffstats
path: root/target/linux/at91/image
diff options
context:
space:
mode:
authorBen Whitten <ben.whitten@gmail.com>2017-06-28 11:28:12 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2017-10-15 00:24:21 +0200
commitf81b353c9f33f5afa32eebe0ee1dc290e927e5ee (patch)
tree2f56e87b245a77d7334b74a25c371796eadfdecc /target/linux/at91/image
parent86d037e4a27fcf8f465fb1e79db727995ad5c684 (diff)
downloadopenwrt-f81b353c9f33f5afa32eebe0ee1dc290e927e5ee.tar.gz
openwrt-f81b353c9f33f5afa32eebe0ee1dc290e927e5ee.tar.bz2
openwrt-f81b353c9f33f5afa32eebe0ee1dc290e927e5ee.zip
at91: add support for the WB50N module from Laird
This module from Laird includes the following: - CPU Atmel SoC SAMA5D31 - Wifi QCA6004 - Bluetooth CSR8811 - RAM 64MB LPDDR - FLASH 128MB The flash is a dual image layout, kernel a/b, rootfs a/b, and a user partition. Signed-off-by: Ben Whitten <ben.whitten@gmail.com>
Diffstat (limited to 'target/linux/at91/image')
-rw-r--r--target/linux/at91/image/sama5.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/target/linux/at91/image/sama5.mk b/target/linux/at91/image/sama5.mk
index 1c779ca327..b26715b8ae 100644
--- a/target/linux/at91/image/sama5.mk
+++ b/target/linux/at91/image/sama5.mk
@@ -29,3 +29,17 @@ define Device/at91-sama5d4_xplained
MKUBIFS_OPTS := -m $$(PAGESIZE) -e 248KiB -c 2082 -x lzo
endef
TARGET_DEVICES += at91-sama5d4_xplained
+
+define Device/wb50n
+ $(Device/evaluation-fit)
+ DEVICE_TITLE := Laird WB50N
+ DEVICE_PACKAGES := \
+ kmod-mmc-at91 kmod-ath6kl-sdio ath6k-firmware \
+ kmod-usb-storage kmod-fs-vfat kmod-fs-msdos \
+ kmod-leds-gpio
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ SUBPAGESIZE := 2048
+ MKUBIFS_OPTS := -m $$(PAGESIZE) -e 124KiB -c 955
+endef
+TARGET_DEVICES += wb50n