summaryrefslogtreecommitdiffstats
path: root/target/linux/ath25/image/Makefile
diff options
context:
space:
mode:
authorLech Perczak <lech.perczak@gmail.com>2022-08-10 01:06:24 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2022-08-13 20:52:37 +0200
commit611291383a826827f240eddebca1949c2e1e7115 (patch)
tree281d660258d1ea96ae89e572398a5f23458f4e11 /target/linux/ath25/image/Makefile
parent85b41cbd3b8e98393232b5f619dcc7378652fbd8 (diff)
downloadopenwrt-611291383a826827f240eddebca1949c2e1e7115.tar.gz
openwrt-611291383a826827f240eddebca1949c2e1e7115.tar.bz2
openwrt-611291383a826827f240eddebca1949c2e1e7115.zip
ath25: fix ELF image generation
Commit 21f460a5dbef ("ath25: fix duplicate LZMA compression"), when attempting to restore ELF artifact generation, copiedover the raw kernel image twice. Because of that, the .elf artifact was actually a duplicate of raw image. Fix that by copying over .elf suffixed kernel image instead. Fixes: 21f460a5dbef ("ath25: fix duplicate LZMA compression") Signed-off-by: Lech Perczak <lech.perczak@gmail.com>
Diffstat (limited to 'target/linux/ath25/image/Makefile')
-rw-r--r--target/linux/ath25/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ath25/image/Makefile b/target/linux/ath25/image/Makefile
index 2b22d54105..d6cd53d261 100644
--- a/target/linux/ath25/image/Makefile
+++ b/target/linux/ath25/image/Makefile
@@ -43,7 +43,7 @@ endef
define Build/copy-kernel
rm -f $@ $@.elf
cp $< $@
- cp $< $@.elf
+ cp $<.elf $@.elf
endef
define Build/elf-kernel