summaryrefslogtreecommitdiffstats
path: root/target/linux/ath25/image/Makefile
diff options
context:
space:
mode:
authorRobert Marko <robimarko@gmail.com>2024-03-05 10:31:48 +0100
committerRobert Marko <robimarko@gmail.com>2024-03-07 12:15:51 +0100
commite247763617ef749a97cad609564ff85878c0aec8 (patch)
tree918b3c316c86ad9ce3eb12b05a8fad8fb40df5f4 /target/linux/ath25/image/Makefile
parent71411cb8b8eeae4521eadfcdf47f1dda15a199a5 (diff)
downloadopenwrt-e247763617ef749a97cad609564ff85878c0aec8.tar.gz
openwrt-e247763617ef749a97cad609564ff85878c0aec8.tar.bz2
openwrt-e247763617ef749a97cad609564ff85878c0aec8.zip
ath25: drop target
ath25 has been on life support for the last couple of releases, eventually leading to marking it as source-only in 2023. It has been basically only touched to do a kernel bump so that we can make the new OpenWrt release which was a challenge due to small RAM amount. However, with the attempt of kernel 6.1 update it turns out that kernel cannot even finish booting due to RAM constraints, so its time to let this target go. Signed-off-by: Robert Marko <robimarko@gmail.com>
Diffstat (limited to 'target/linux/ath25/image/Makefile')
-rw-r--r--target/linux/ath25/image/Makefile118
1 files changed, 0 insertions, 118 deletions
diff --git a/target/linux/ath25/image/Makefile b/target/linux/ath25/image/Makefile
deleted file mode 100644
index 9cdcdf9e95..0000000000
--- a/target/linux/ath25/image/Makefile
+++ /dev/null
@@ -1,118 +0,0 @@
-# SPDX-License-Identifier: GPL-2.0-only
-#
-# Copyright (C) 2006-2010 OpenWrt.org
-
-include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/image.mk
-
-define Build/mkfwimage
- $(STAGING_DIR_HOST)/bin/mkfwimage \
- -B $(1).$(VERSION_DIST).$(REVISION) \
- -k $(IMAGE_KERNEL) \
- -r $(IMAGE_ROOTFS) \
- -o $@.new && \
- mv $@.new $@
-endef
-
-define Build/combined-image
- -sh $(TOPDIR)/scripts/combined-image.sh \
- "$(IMAGE_KERNEL)" \
- "$(IMAGE_ROOTFS)" \
- "$@.new" && \
- mv $@.new $@
-endef
-
-define Build/mkmylofw
- $(STAGING_DIR_HOST)/bin/mkmylofw -B $(1) \
- -p0x020000:0x130000:ah:0x80041000:linux:$(IMAGE_KERNEL) \
- -p0x150000:0x2a0000:::rootfs:$(IMAGE_ROOTFS) \
- $@.new && \
- mv $@.new $@
-endef
-
-define Build/gzip-kernel
- gzip -9n -c $@ > $@.gz
- dd if=$@.gz of=$@ bs=65536 conv=sync
-endef
-
-define Build/lzma-kernel
- $(STAGING_DIR_HOST)/bin/lzma e $@ $@.l7
- dd if=$@.l7 of=$@ bs=65536 conv=sync
-endef
-
-define Build/copy-kernel
- rm -f $@ $@.elf
- cp $< $@
- cp $<.elf $@.elf
-endef
-
-define Build/elf-kernel
- cp $(IMAGE_KERNEL).elf $@
-endef
-
-
-define Device/Default
- PROFILES = Default $$(DEVICE_NAME)
- KERNEL := copy-kernel | lzma-kernel
- KERNEL_INITRAMFS = kernel-bin
- KERNEL_INITRAMFS_NAME := vmlinux-initramfs.elf
- KERNEL_INITRAMFS_SUFFIX := -kernel.elf
- IMAGES := sysupgrade.bin
- FILESYSTEMS := squashfs
-endef
-
-define Device/generic
- DEVICE_VENDOR := Atheros
- DEVICE_MODEL := Generic AR2xxx board
- IMAGES := kernel.lzma kernel.elf kernel.gz rootfs.bin sysupgrade.bin
- IMAGE/kernel.gz := elf-kernel | gzip-kernel
- IMAGE/kernel.elf := elf-kernel
- IMAGE/kernel.lzma := elf-kernel | lzma-kernel
- IMAGE/rootfs.bin := append-rootfs | pad-rootfs | pad-to 128k
- IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | pad-to 128k | combined-image
- DEVICE_IMG_NAME = $$(DEVICE_IMG_PREFIX)-$$(if $$(findstring kernel,$$(2)),,$$(1)-)$$(2)
-endef
-TARGET_DEVICES += generic
-
-define Device/ubnt_picostation-2
- DEVICE_VENDOR := Ubiquiti
- DEVICE_MODEL := Picostation 2 (XS2-8)
- IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | pad-to 128k | mkfwimage XS2-8 -v XS2.ar2316
-endef
-TARGET_DEVICES += ubnt_picostation-2
-
-define Device/ubnt_nanostation-2
- DEVICE_VENDOR := Ubiquiti
- DEVICE_MODEL := Nanostation 2 (XS2)
- IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | pad-to 128k | mkfwimage XS2 -v XS2.ar2316
- DEFAULT := n
-endef
-TARGET_DEVICES += ubnt_nanostation-2
-
-define Device/ubnt_nanostation-5
- DEVICE_VENDOR := Ubiquiti
- DEVICE_MODEL := Nanostation 5 (XS5)
- IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | pad-to 128k | mkfwimage XS5 -v XS5.ar2313
- DEFAULT := n
-endef
-TARGET_DEVICES += ubnt_nanostation-5
-
-define Device/compex_np25g
- DEVICE_VENDOR := Compex
- DEVICE_MODEL := NP25G
- KERNEL := kernel-bin | gzip-kernel
- IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | pad-to 128k | mkmylofw np25g
- BROKEN := y
-endef
-TARGET_DEVICES += compex_np25g
-
-define Device/compex_wpe53g
- DEVICE_VENDOR := Compex
- DEVICE_MODEL := WPE53G
- KERNEL := kernel-bin | gzip-kernel
- IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | pad-to 128k | mkmylofw wpe53g
- BROKEN := y
-endef
-TARGET_DEVICES += compex_wpe53g
-
-$(eval $(call BuildImage))