summaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
authorKorey Caro <korey.caro@gmail.com>2022-03-12 23:36:30 -0500
committerHauke Mehrtens <hauke@hauke-m.de>2022-11-06 00:51:58 +0100
commit12cee869890853716ff1ee2dbd0a89c87a0ee544 (patch)
treea50972f4466a5012954f362846cd6c8c65ca478b /target/linux/ath79/image/generic.mk
parent6645a019f88e2e6930fe63d1a51046a8e72445a0 (diff)
downloadopenwrt-12cee869890853716ff1ee2dbd0a89c87a0ee544.tar.gz
openwrt-12cee869890853716ff1ee2dbd0a89c87a0ee544.tar.bz2
openwrt-12cee869890853716ff1ee2dbd0a89c87a0ee544.zip
ath79: add support to TrendNet TEW-673GRU
Add support for the TrendNet TEW-673GRU to ath79. This device was supported in 19.07.9 but was deprecated with ar71xx. This is mostly a copy of D-Link DIR-825 B1. Updates have been completed to enable factory.bin and sysupgrade.bin both. Code improvements to DTS file and makefile. Architecture | MIPS Vendor | Qualcomm Atheros bootloader | U-Boot System-On-Chip | AR7161 rev 2 (MIPS 24Kc V7.4) CPU/Speed | 24Kc V7.4 680 MHz Flash-Chip | Macronix MX25L6405D Flash size | 8192 KiB RAM Chip: | ProMOS V58C2256164SCI5 × 2 RAM size | 64 MiB Wireless | 2 x Atheros AR922X 2.4GHz/5.0GHz 802.11abgn Ethernet | RealTek RTL8366S Gigabit w/ port based vlan support USB | Yes 2 x 2.0 Initial Flashing Process: 1) Download 22.03 tew-673gru factory bin 2) Flash 22.03 using TrendNet GUI OpenWRT Upgrade Process 3) Download 22.03 tew-673gru sysupgrade.bin 4) Flash 22.03 using OpenWRT GUI Signed-off-by: Korey Caro <korey.caro@gmail.com>
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 7b760abc3e..11c5669fe4 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -2554,6 +2554,22 @@ define Device/teltonika_rut955-h7v3c0
endef
TARGET_DEVICES += teltonika_rut955-h7v3c0
+define Device/trendnet_tew-673gru
+ SOC := ar7161
+ DEVICE_VENDOR := Trendnet
+ DEVICE_MODEL := TEW-673GRU
+ DEVICE_VARIANT := v1.0R
+ DEVICE_PACKAGES := -uboot-envtools kmod-usb-ohci kmod-usb2 \
+ kmod-owl-loader kmod-switch-rtl8366s
+ IMAGE_SIZE := 7808k
+ FACTORY_SIZE := 6144k
+ IMAGES += factory.bin
+ IMAGE/factory.bin = append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | \
+ pad-rootfs | check-size $$$$(FACTORY_SIZE) | pad-to $$$$(FACTORY_SIZE) | \
+ append-string AP94-AR7161-RT-080619-01
+endef
+TARGET_DEVICES += trendnet_tew-673gru
+
define Device/trendnet_tew-823dru
SOC := qca9558
DEVICE_VENDOR := Trendnet