summaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2023-04-03 13:56:58 +0200
committerDavid Bauer <mail@david-bauer.net>2023-06-23 00:20:56 +0200
commit1b467a902ec9b8bf29805c6928627e8bbad0f14c (patch)
tree802d7b35a3f3021ecd3fa64fdee2f84311589907 /target/linux/ath79/image/generic.mk
parentdf8e4b6c2e6440bc9a31467de1739c69c328e391 (diff)
downloadopenwrt-1b467a902ec9b8bf29805c6928627e8bbad0f14c.tar.gz
openwrt-1b467a902ec9b8bf29805c6928627e8bbad0f14c.tar.bz2
openwrt-1b467a902ec9b8bf29805c6928627e8bbad0f14c.zip
ath79: add support for Aruba AP-115
Hardware ======== CPU Qualcomm Atheros QCA9558 RAM 256MB DDR2 FLASH 2x 16M SPI-NOR (Macronix MX25L12805D) WIFI Qualcomm Atheros QCA9558 Atheros AR9590 Installation ============ 1. Attach to the serial console of the AP-105. Interrupt autoboot and change the U-Boot env. $ setenv rb_openwrt "setenv ipaddr 192.168.1.1; setenv serverip 192.168.1.66; netget 0x80060000 ap115.bin; go 0x80060000" $ setenv fb_openwrt "bank 1; cp.b 0xbf100040 0x80060000 0x10000; go 0x80060000" $ setenv bootcmd "run fb_openwrt" $ saveenv 2. Load the OpenWrt initramfs image on the device using TFTP. Place the initramfs image as "ap105.bin" in the TFTP server root directory, connect it to the AP and make the server reachable at 192.168.1.66/24. $ run rb_openwrt 3. Once OpenWrt booted, transfer the sysupgrade image to the device using scp and use sysupgrade to install the firmware. Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 788520120d..1a558c30a0 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -413,6 +413,21 @@ define Device/aruba_ap-105
endef
TARGET_DEVICES += aruba_ap-105
+define Device/aruba_ap-115
+ SOC := qca9558
+ DEVICE_VENDOR := Aruba
+ DEVICE_MODEL := AP-115
+ IMAGE_SIZE := 16000k
+ DEVICE_PACKAGES := kmod-usb2
+ LOADER_TYPE := bin
+ LOADER_FLASH_OFFS := 0x102000
+ COMPILE := loader-$(1).bin
+ COMPILE/loader-$(1).bin := loader-okli-compile
+ KERNEL := kernel-bin | append-dtb | lzma | uImage lzma -M 0x4f4b4c49 | loader-okli $(1) 8128 | uImage none
+ KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma | loader-kernel
+endef
+TARGET_DEVICES += aruba_ap-115
+
define Device/aruba_ap-175
SOC := ar7161
DEVICE_VENDOR := Aruba