summaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
authorShiji Yang <yangshiji66@qq.com>2024-03-19 21:25:52 +0800
committerHauke Mehrtens <hauke@hauke-m.de>2024-03-30 01:04:17 +0100
commit8201e402c5485817eaf8838347b35e48f7086739 (patch)
tree72658f1eee67a5b0a4b6721e31e787aab868eb3e /target/linux/ath79/image/generic.mk
parent9a6c1846bb40879fccf42070ec3bf4daa9732e93 (diff)
downloadopenwrt-8201e402c5485817eaf8838347b35e48f7086739.tar.gz
openwrt-8201e402c5485817eaf8838347b35e48f7086739.tar.bz2
openwrt-8201e402c5485817eaf8838347b35e48f7086739.zip
ath79: move D-Link DIR-859 and DIR-869 series to tiny sub-target
These devices only have 64 MiB RAM and ath10k wireless driver will consume a lot of memory. Let's move them to the tiny sub-target to get extra 7 MiB of free space. In this way, we can extend their lifetime to receive support for the next OpenWrt LTS version. This patch also trims the USB package for the non-existent USB port. Signed-off-by: Shiji Yang <yangshiji66@qq.com>
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk35
1 files changed, 0 insertions, 35 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index d56afcaac8..03a0472c12 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -1278,41 +1278,6 @@ define Device/dlink_dir-842-c3
endef
TARGET_DEVICES += dlink_dir-842-c3
-define Device/dlink_dir-859-ax
- $(Device/seama)
- SOC := qca9563
- DEVICE_VENDOR := D-Link
- DEVICE_MODEL := DIR-859
- IMAGE_SIZE := 15872k
- DEVICE_PACKAGES := kmod-usb2 kmod-ath10k-ct-smallbuffers ath10k-firmware-qca988x-ct
- SEAMA_SIGNATURE := wrgac37_dlink.2013gui_dir859
-endef
-
-define Device/dlink_dir-859-a1
- $(Device/dlink_dir-859-ax)
- DEVICE_VARIANT := A1
-endef
-TARGET_DEVICES += dlink_dir-859-a1
-
-define Device/dlink_dir-859-a3
- $(Device/dlink_dir-859-ax)
- DEVICE_VARIANT := A3
-endef
-TARGET_DEVICES += dlink_dir-859-a3
-
-define Device/dlink_dir-869-a1
- $(Device/seama)
- SOC := qca9563
- DEVICE_VENDOR := D-Link
- DEVICE_MODEL := DIR-869
- DEVICE_VARIANT := A1
- IMAGE_SIZE := 15872k
- DEVICE_PACKAGES := kmod-usb2 kmod-ath10k-ct-smallbuffers ath10k-firmware-qca988x-ct
- SEAMA_SIGNATURE := wrgac54_dlink.2015_dir869
- SUPPORTED_DEVICES += dir-869-a1
-endef
-TARGET_DEVICES += dlink_dir-869-a1
-
define Device/elecom_wab
DEVICE_VENDOR := ELECOM
IMAGE_SIZE := 14336k