summaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
authorShiji Yang <yangshiji66@qq.com>2024-03-19 21:25:52 +0800
committerHauke Mehrtens <hauke@hauke-m.de>2024-03-30 01:04:17 +0100
commit82208eb52785da3cce48cfa47849436aa77e985c (patch)
tree57e6bfdaf7e63ecd7f59df9520ad63f187607f29 /target/linux/ath79/image/generic.mk
parent60061b5c26b65004377a886f917bcd3005e97dad (diff)
downloadopenwrt-82208eb52785da3cce48cfa47849436aa77e985c.tar.gz
openwrt-82208eb52785da3cce48cfa47849436aa77e985c.tar.bz2
openwrt-82208eb52785da3cce48cfa47849436aa77e985c.zip
ath79: move seama image recipe to the common Makefile
Move seama image recipe to the common Makefile in order for some tiny sub-target D-Link devices can share it. Signed-off-by: Shiji Yang <yangshiji66@qq.com>
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk18
1 files changed, 0 insertions, 18 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index e7960efbaa..d56afcaac8 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -6,7 +6,6 @@ include ./common-yuncore.mk
include ./common-ubnt.mk
DEVICE_VARS += ADDPATTERN_ID ADDPATTERN_VERSION
-DEVICE_VARS += SEAMA_SIGNATURE SEAMA_MTDBLOCK
DEVICE_VARS += KERNEL_INITRAMFS_PREFIX DAP_SIGNATURE
DEVICE_VARS += EDIMAX_HEADER_MAGIC EDIMAX_HEADER_MODEL
DEVICE_VARS += ELECOM_HWID
@@ -194,23 +193,6 @@ define Build/zyxel-tar-bz2
rm -rf $@.tmp
endef
-define Device/seama
- KERNEL := kernel-bin | append-dtb | relocate-kernel | lzma
- KERNEL_INITRAMFS := $$(KERNEL) | seama
- IMAGES += factory.bin
- SEAMA_MTDBLOCK := 1
-
- # 64 bytes offset:
- # - 28 bytes seama_header
- # - 36 bytes of META data (4-bytes aligned)
- IMAGE/default := append-kernel | pad-offset $$$$(BLOCKSIZE) 64 | append-rootfs
- IMAGE/sysupgrade.bin := $$(IMAGE/default) | seama | pad-rootfs | \
- check-size | append-metadata
- IMAGE/factory.bin := $$(IMAGE/default) | pad-rootfs -x 64 | seama | \
- seama-seal | check-size
- SEAMA_SIGNATURE :=
-endef
-
define Device/8dev_carambola2
SOC := ar9331