summaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
authorSebastian Schaper <openwrt@sebastianschaper.net>2024-02-11 18:55:43 +0100
committerChristian Lamparter <chunkeey@gmail.com>2024-03-09 20:00:11 +0100
commitee69f81ca5032f13e39ce7c2515ae9c5ee0a78f1 (patch)
tree07a6541508852bed44fe3db63d7963239402dc67 /target/linux/ath79/image/generic.mk
parent6fa2ae30bbfa0fb0919fcd0dd3b96b185594c7f1 (diff)
downloadopenwrt-ee69f81ca5032f13e39ce7c2515ae9c5ee0a78f1.tar.gz
openwrt-ee69f81ca5032f13e39ce7c2515ae9c5ee0a78f1.tar.bz2
openwrt-ee69f81ca5032f13e39ce7c2515ae9c5ee0a78f1.zip
ath79: add support for D-Link COVR-C1200 A1
The COVR-C1200 devices are sold as "Whole Home Mesh Wi-Fi" sets in packs of two (COVR-C1202) and three (COVR-C1203). Specifications: * QCA9563, 16 MiB flash, 128 MiB RAM, 2x3:2 802.11n * QCA9886 2x2:2 801.11ac Wave 2 * AR8337, 2 Gigabit ports (1: WAN; 2: LAN) * USB Type-C power connector (5V, 3A) Installation COVR Point A: * In factory reset state: OEM Web UI is at 192.168.0.50 no DHCP, skip wizard by directly accessing: http://192.168.0.50/UpdateFirmware_Simple.html * After completing setup wizard: Web UI is at 192.168.0.1 DHCP enabled, login with empty password * Flash factory.bin * Perform a factory reset to restore OpenWrt UCI defaults Installation COVR Points B: * OEM Web UI is at 192.168.0.50, no DHCP, empty password * Flash factory.bin * Perform a factory reset to restore OpenWrt UCI defaults Recovery: * Keep reset button pressed during power on * Recovery Web UI is at 192.168.0.50, no DHCP * Flash factory.bin used to work best with Chromium-based browsers or curl: curl -F firmware=@factory.bin \ http://192.168.0.50/upgrade.cgi since this fails to work on modern Linux systems, there is also a script dlink_recovery_upload.py Signed-off-by: Sebastian Schaper <openwrt@sebastianschaper.net>
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index d5d8aa5592..e7960efbaa 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -1021,6 +1021,16 @@ define Device/dlink_covr
append-loader-okli-uimage $(1) | pad-to 15616k
endef
+define Device/dlink_covr-c1200-a1
+ $(Device/dlink_covr)
+ DEVICE_MODEL := COVR-C1200
+ DEVICE_VARIANT := A1
+ IMAGES += factory.bin
+ IMAGE/factory.bin := $$(IMAGE/recovery.bin) | \
+ dlink-sge-signature COVR-C1200 | dlink-sge-image COVR-C1200
+endef
+TARGET_DEVICES += dlink_covr-c1200-a1
+
define Device/dlink_covr-p2500-a1
$(Device/dlink_covr)
DEVICE_MODEL := COVR-P2500