summaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
authorWenli Looi <wlooi@ucalgary.ca>2022-11-22 18:34:37 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2023-01-25 00:42:52 +0100
commitf0eb73a888e2ed980b0943d4a2e4d19ad0af183a (patch)
tree6274bf1941220e5f2415cdb78122f6b62f866afb /target/linux/ath79/image/generic.mk
parentf0e4595188db797446f7b3d29a6162ede90586a6 (diff)
downloadopenwrt-f0eb73a888e2ed980b0943d4a2e4d19ad0af183a.tar.gz
openwrt-f0eb73a888e2ed980b0943d4a2e4d19ad0af183a.tar.bz2
openwrt-f0eb73a888e2ed980b0943d4a2e4d19ad0af183a.zip
ath79: consolidate Netgear EX7300 series images
This change consolidates Netgear EX7300 series devices into two images corresponding to devices that share the same manufacturer firmware image. Similar to the manufacturer firmware, the actual device model is detected at runtime. The logic is taken from the netgear GPL dumps in a file called generate_board_conf.sh. Hardware details for EX7300 v2 variants --------------------------------------- SoC: QCN5502 Flash: 16 MiB RAM: 128 MiB Ethernet: 1 gigabit port Wireless 2.4GHz (currently unsupported due to lack of ath9k support): - EX6250 / EX6400 v2 / EX6410 / EX6420: QCN5502 3x3 - EX7300 v2 / EX7320: QCN5502 4x4 Wireless 5GHz: - EX6250: QCA9986 3x3 (detected by ath10k as QCA9984 3x3) - EX6400 v2 / EX6410 / EX6420 / EX7300 v2 / EX7320: QCA9984 4x4 Signed-off-by: Wenli Looi <wlooi@ucalgary.ca>
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk36
1 files changed, 20 insertions, 16 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index ec7cbb950a..7712247d39 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -1732,41 +1732,45 @@ define Device/nec_wg800hp
endef
TARGET_DEVICES += nec_wg800hp
-define Device/netgear_ex6400_ex7300
- $(Device/netgear_generic)
+define Device/netgear_ex7300
SOC := qca9558
- UIMAGE_MAGIC := 0x27051956
+ DEVICE_VENDOR := NETGEAR
+ DEVICE_MODEL := EX7300
+ DEVICE_ALT0_VENDOR := NETGEAR
+ DEVICE_ALT0_MODEL := EX6400
NETGEAR_BOARD_ID := EX7300series
NETGEAR_HW_ID := 29765104+16+0+128
IMAGE_SIZE := 15552k
+ IMAGES += factory.img
IMAGE/default := append-kernel | pad-offset $$$$(BLOCKSIZE) 64 | \
netgear-rootfs | pad-rootfs
IMAGE/sysupgrade.bin := $$(IMAGE/default) | check-size | append-metadata
IMAGE/factory.img := $$(IMAGE/default) | netgear-dni | check-size
DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca99x0-ct
-endef
-
-define Device/netgear_ex6400
- $(Device/netgear_ex6400_ex7300)
- DEVICE_MODEL := EX6400
-endef
-TARGET_DEVICES += netgear_ex6400
-
-define Device/netgear_ex7300
- $(Device/netgear_ex6400_ex7300)
- DEVICE_MODEL := EX7300
+ SUPPORTED_DEVICES += netgear,ex6400
endef
TARGET_DEVICES += netgear_ex7300
define Device/netgear_ex7300-v2
- $(Device/netgear_generic)
SOC := qcn5502
+ DEVICE_VENDOR := NETGEAR
DEVICE_MODEL := EX7300
DEVICE_VARIANT := v2
- UIMAGE_MAGIC := 0x27051956
+ DEVICE_ALT0_VENDOR := NETGEAR
+ DEVICE_ALT0_MODEL := EX6250
+ DEVICE_ALT1_VENDOR := NETGEAR
+ DEVICE_ALT1_MODEL := EX6400
+ DEVICE_ALT1_VARIANT := v2
+ DEVICE_ALT2_VENDOR := NETGEAR
+ DEVICE_ALT2_MODEL := EX6410
+ DEVICE_ALT3_VENDOR := NETGEAR
+ DEVICE_ALT3_MODEL := EX6420
+ DEVICE_ALT4_VENDOR := NETGEAR
+ DEVICE_ALT4_MODEL := EX7320
NETGEAR_BOARD_ID := EX7300v2series
NETGEAR_HW_ID := 29765907+16+0+128
IMAGE_SIZE := 14528k
+ IMAGES += factory.img
IMAGE/default := append-kernel | pad-offset $$$$(BLOCKSIZE) 64 | \
netgear-rootfs | pad-rootfs
IMAGE/sysupgrade.bin := $$(IMAGE/default) | check-size | append-metadata