summaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/patches-5.10/420-net-use-downstream-ag71xx.patch
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2021-02-17 01:29:44 +0100
committerDavid Bauer <mail@david-bauer.net>2021-02-20 01:26:33 +0100
commitd6b785d47739a84611088ab26256fa5808d06a9d (patch)
treed45ffa6e6182ce80ec35663de8c514888655e1b8 /target/linux/ath79/patches-5.10/420-net-use-downstream-ag71xx.patch
parentfb64e2c30f0cba887d3b183ce52de36b3e8bbb7e (diff)
downloadopenwrt-d6b785d47739a84611088ab26256fa5808d06a9d.tar.gz
openwrt-d6b785d47739a84611088ab26256fa5808d06a9d.tar.bz2
openwrt-d6b785d47739a84611088ab26256fa5808d06a9d.zip
ath79: add kernel 5.10 support
This adds Kernel 5.10 support for the generic, nand and tiny subtargets. The following patch is not contained, as it needs to be reworked: platform/920-mikrotik-rb4xx.patch Tested-on: - Siemens WS-AP3610 - Enterasys WS-AP3710 - Aerohive HiveAP 121 - TP-Link TL-WA901 v2 - TP-Link TL-WR741 v1 Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/ath79/patches-5.10/420-net-use-downstream-ag71xx.patch')
-rw-r--r--target/linux/ath79/patches-5.10/420-net-use-downstream-ag71xx.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/target/linux/ath79/patches-5.10/420-net-use-downstream-ag71xx.patch b/target/linux/ath79/patches-5.10/420-net-use-downstream-ag71xx.patch
new file mode 100644
index 0000000000..7ce3f0d29c
--- /dev/null
+++ b/target/linux/ath79/patches-5.10/420-net-use-downstream-ag71xx.patch
@@ -0,0 +1,28 @@
+--- a/drivers/net/ethernet/atheros/Kconfig
++++ b/drivers/net/ethernet/atheros/Kconfig
+@@ -17,13 +17,7 @@ config NET_VENDOR_ATHEROS
+
+ if NET_VENDOR_ATHEROS
+
+-config AG71XX
+- tristate "Atheros AR7XXX/AR9XXX built-in ethernet mac support"
+- depends on ATH79
+- select PHYLINK
+- help
+- If you wish to compile a kernel for AR7XXX/91XXX and enable
+- ethernet support, then you should always answer Y to this.
++source "drivers/net/ethernet/atheros/ag71xx/Kconfig"
+
+ config ATL2
+ tristate "Atheros L2 Fast Ethernet support"
+--- a/drivers/net/ethernet/atheros/Makefile
++++ b/drivers/net/ethernet/atheros/Makefile
+@@ -3,7 +3,7 @@
+ # Makefile for the Atheros network device drivers.
+ #
+
+-obj-$(CONFIG_AG71XX) += ag71xx.o
++obj-$(CONFIG_AG71XX) += ag71xx/
+ obj-$(CONFIG_ATL1) += atlx/
+ obj-$(CONFIG_ATL2) += atlx/
+ obj-$(CONFIG_ATL1E) += atl1e/