summaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/patches-5.10/939-mikrotik-rb91x.patch
diff options
context:
space:
mode:
authorOlliver Schinagl <oliver@schinagl.nl>2022-09-20 12:01:48 +0200
committerChristian Marangi <ansuelsmth@gmail.com>2022-10-01 02:47:56 +0200
commitba6096d04b4f7a40aec339e7bf3f7b5842ae3cac (patch)
tree5542eb3332cf44995b052240ed32bcf7e9434beb /target/linux/ath79/patches-5.10/939-mikrotik-rb91x.patch
parentd5bf46bbe8f425182ea07787ae5d92145715da1b (diff)
downloadopenwrt-ba6096d04b4f7a40aec339e7bf3f7b5842ae3cac.tar.gz
openwrt-ba6096d04b4f7a40aec339e7bf3f7b5842ae3cac.tar.bz2
openwrt-ba6096d04b4f7a40aec339e7bf3f7b5842ae3cac.zip
ath79: Convert incorrect 5.10 and 5.15 patches
OpenWRT's developer guide prefers having actual patches so they an be sent upstream more easily. However, in this case, Adding proper fields also allows for `git am` to properly function. Some of these patches are quite old, and lack much traceable history. This commit tries to rectify that, by digging in the history to find where and how it was first added. It is by no means perfect and also shows some patches that should have been long gone. Signed-off-by: Olliver Schinagl <oliver@schinagl.nl>
Diffstat (limited to 'target/linux/ath79/patches-5.10/939-mikrotik-rb91x.patch')
-rw-r--r--target/linux/ath79/patches-5.10/939-mikrotik-rb91x.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/target/linux/ath79/patches-5.10/939-mikrotik-rb91x.patch b/target/linux/ath79/patches-5.10/939-mikrotik-rb91x.patch
index 4cf6bb08df..7990061cbd 100644
--- a/target/linux/ath79/patches-5.10/939-mikrotik-rb91x.patch
+++ b/target/linux/ath79/patches-5.10/939-mikrotik-rb91x.patch
@@ -1,3 +1,32 @@
+From: Denis Kalashnikov <denis281089@gmail.com>
+Subject: [PATCH] ath79: add support for reset key on MikroTik RB912UAG-2HPnD
+
+On MikroTik RB91x board series a reset key shares SoC gpio
+line #15 with NAND ALE and NAND IO7. So we need a custom
+gpio driver to manage this non-trivial connection schema.
+Also rb91x-nand needs to have an ability to disable a polling
+of the key while it works with NAND.
+
+While we've been integrating rb91x-key into a firmware, we've
+figured out that:
+* In the gpio-latch driver we need to add a "cansleep" suffix to
+several gpiolib calls,
+* When gpio-latch and rb91x-nand fail to get a gpio and an error
+is -EPROBE_DEFER, they shouldn't report about this, since this
+actually is not an error and occurs when the gpio-latch probe
+function is called before the rb91x-key probe.
+We fix these related things here too.
+
+Submitted-by: Denis Kalashnikov <denis281089@gmail.com>
+Reviewed-by: Sergey Ryazanov <ryazanov.s.a@gmail.com>
+Tested-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
+---
+ drivers/gpio/Kconfig | 11 +++++++++++
+ drivers/gpio/Makefile | 2 ++
+ drivers/mtd/nand/raw/Kconfig | 6 ++++++
+ drivers/mtd/nand/raw/Makefile | 1 +
+ 7 files changed, 20 insertions(+)
+
--- a/drivers/gpio/Kconfig
+++ b/drivers/gpio/Kconfig
@@ -341,6 +341,13 @@ config GPIO_IXP4XX