summaryrefslogtreecommitdiffstats
path: root/target/linux/ath79
diff options
context:
space:
mode:
authorChristoph Krapp <achterin@googlemail.com>2019-01-01 12:03:20 +0000
committerMathias Kresin <dev@kresin.me>2019-01-01 19:42:41 +0100
commit59b99e192480a773489d38784682e11436f38f3c (patch)
tree58ee625ee99ee9b0bc0fdbffb6aaa012f0b8b1e8 /target/linux/ath79
parent257de1b01f985a96a08ba26f2feb5cffec89b911 (diff)
downloadopenwrt-59b99e192480a773489d38784682e11436f38f3c.tar.gz
openwrt-59b99e192480a773489d38784682e11436f38f3c.tar.bz2
openwrt-59b99e192480a773489d38784682e11436f38f3c.zip
ath79: align GL-AR750S boardname to other GL.iNet devices
As the official device name is GL-AR750S, rename the board accordingly. Signed-off-by: Christoph Krapp <achterin@googlemail.com>
Diffstat (limited to 'target/linux/ath79')
-rwxr-xr-xtarget/linux/ath79/base-files/etc/board.d/02_network2
-rw-r--r--target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata9
-rw-r--r--target/linux/ath79/dts/qca9563_glinet_gl-ar750s.dts (renamed from target/linux/ath79/dts/qca9563_glinet_ar750s.dts)2
-rw-r--r--target/linux/ath79/image/generic.mk4
4 files changed, 7 insertions, 10 deletions
diff --git a/target/linux/ath79/base-files/etc/board.d/02_network b/target/linux/ath79/base-files/etc/board.d/02_network
index e24c58e208..6776506893 100755
--- a/target/linux/ath79/base-files/etc/board.d/02_network
+++ b/target/linux/ath79/base-files/etc/board.d/02_network
@@ -100,7 +100,7 @@ ath79_setup_interfaces()
tplink,tl-wr810n-v2)
ucidef_set_interfaces_lan_wan "eth1" "eth0"
;;
- glinet,ar750s)
+ glinet,gl-ar750s)
ucidef_add_switch "switch0" \
"0@eth0" "2:lan:2" "3:lan:1" "1:wan"
;;
diff --git a/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata b/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
index 441893a752..faee781970 100644
--- a/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
+++ b/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
@@ -99,13 +99,10 @@ case "$FIRMWARE" in
elecom,wrc-1750ghbk2-i)
ath10kcal_extract "ART" 20480 2116
;;
- glinet,ar750s|\
- tplink,re450-v2)
- ath10kcal_extract "art" 20480 2116
- ath10kcal_patch_mac $(macaddr_add $(cat /sys/class/net/eth0/address) +1)
- ;;
engenius,ews511ap|\
- glinet,gl-x750)
+ glinet,gl-ar750s|\
+ glinet,gl-x750|\
+ tplink,re450-v2)
ath10kcal_extract "art" 20480 2116
ath10kcal_patch_mac $(macaddr_add $(cat /sys/class/net/eth0/address) +1)
;;
diff --git a/target/linux/ath79/dts/qca9563_glinet_ar750s.dts b/target/linux/ath79/dts/qca9563_glinet_gl-ar750s.dts
index ab33bc13e3..439acaae85 100644
--- a/target/linux/ath79/dts/qca9563_glinet_ar750s.dts
+++ b/target/linux/ath79/dts/qca9563_glinet_gl-ar750s.dts
@@ -7,7 +7,7 @@
#include "qca956x.dtsi"
/ {
- compatible = "glinet,ar750s", "qca,qca9563";
+ compatible = "glinet,gl-ar750s", "qca,qca9563";
model = "GL.iNet GL-AR750S";
chosen {
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 326633835d..858c1662cc 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -289,14 +289,14 @@ define Device/glinet_gl-ar300m-nor
endef
TARGET_DEVICES += glinet_gl-ar300m-nor
-define Device/glinet_ar750s
+define Device/glinet_gl-ar750s
ATH_SOC := qca9563
DEVICE_TITLE := GL.iNet GL-AR750S
DEVICE_PACKAGES := kmod-usb2 kmod-ath10k-ct ath10k-firmware-qca988x-ct
IMAGE_SIZE := 16000k
SUPPORTED_DEVICES += gl-ar750s
endef
-TARGET_DEVICES += glinet_ar750s
+TARGET_DEVICES += glinet_gl-ar750s
define Device/glinet_gl-x750
ATH_SOC := qca9531