summaryrefslogtreecommitdiffstats
path: root/target/linux/bcm27xx/modules
diff options
context:
space:
mode:
authorÁlvaro Fernández Rojas <noltari@gmail.com>2022-05-16 23:40:32 +0200
committerÁlvaro Fernández Rojas <noltari@gmail.com>2022-05-17 15:11:22 +0200
commit20ea6adbf199097c4f5f591ffee088340630dae4 (patch)
treed6719d95e136611a1c25bbf7789652d6d402779d /target/linux/bcm27xx/modules
parentbca05bd072180dc38ef740b37ded9572a6db1981 (diff)
downloadopenwrt-20ea6adbf199097c4f5f591ffee088340630dae4.tar.gz
openwrt-20ea6adbf199097c4f5f591ffee088340630dae4.tar.bz2
openwrt-20ea6adbf199097c4f5f591ffee088340630dae4.zip
bcm27xx: add support for linux v5.15
Build system: x86_64 Build-tested: bcm2708, bcm2709, bcm2710, bcm2711 Run-tested: bcm2708/RPiB+, bcm2709/RPi3B, bcm2710/RPi3B, bcm2711/RPi4B Signed-off-by: Marty Jones <mj8263788@gmail.com> Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Diffstat (limited to 'target/linux/bcm27xx/modules')
-rw-r--r--target/linux/bcm27xx/modules/hwmon.mk2
-rw-r--r--target/linux/bcm27xx/modules/other.mk18
-rw-r--r--target/linux/bcm27xx/modules/sound.mk1
3 files changed, 20 insertions, 1 deletions
diff --git a/target/linux/bcm27xx/modules/hwmon.mk b/target/linux/bcm27xx/modules/hwmon.mk
index 316f0b8419..02ac204e1a 100644
--- a/target/linux/bcm27xx/modules/hwmon.mk
+++ b/target/linux/bcm27xx/modules/hwmon.mk
@@ -20,7 +20,7 @@ $(eval $(call KernelPackage,hwmon-raspberrypi))
define KernelPackage/hwmon-rpi-poe-fan
SUBMENU:=$(HWMON_MENU)
TITLE:=Raspberry Pi PoE HAT fan
- DEPENDS:=@TARGET_bcm27xx +kmod-hwmon-core
+ DEPENDS:=@TARGET_bcm27xx @LINUX_5_10 +kmod-hwmon-core
KCONFIG:=CONFIG_SENSORS_RPI_POE_FAN
FILES:=$(LINUX_DIR)/drivers/hwmon/rpi-poe-fan.ko
AUTOLOAD:=$(call AutoProbe,rpi-poe-fan)
diff --git a/target/linux/bcm27xx/modules/other.mk b/target/linux/bcm27xx/modules/other.mk
index 2d4aa3c079..5f37e498d0 100644
--- a/target/linux/bcm27xx/modules/other.mk
+++ b/target/linux/bcm27xx/modules/other.mk
@@ -20,6 +20,24 @@ endef
$(eval $(call KernelPackage,pwm-bcm2835))
+define KernelPackage/pwm-raspberrypi-poe
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Raspberry Pi Firwmware PoE Hat PWM support
+ KCONFIG:= \
+ CONFIG_PWM=y \
+ CONFIG_PWM_RASPBERRYPI_POE
+ FILES:=$(LINUX_DIR)/drivers/pwm/pwm-raspberrypi-poe.ko
+ AUTOLOAD:=$(call AutoLoad,20,pwm-raspberrypi-poe)
+ DEPENDS:=@TARGET_bcm27xx @LINUX_5_15
+endef
+
+define KernelPackage/pwm-raspberrypi-poe/description
+ This package provides Raspberry Pi Firwmware PoE Hat PWM support
+endef
+
+$(eval $(call KernelPackage,pwm-raspberrypi-poe))
+
+
define KernelPackage/smi-bcm2835
SUBMENU:=$(OTHER_MENU)
TITLE:=BCM2835 SMI driver
diff --git a/target/linux/bcm27xx/modules/sound.mk b/target/linux/bcm27xx/modules/sound.mk
index 0823786d5c..f6372f6870 100644
--- a/target/linux/bcm27xx/modules/sound.mk
+++ b/target/linux/bcm27xx/modules/sound.mk
@@ -932,6 +932,7 @@ define KernelPackage/sound-soc-rpi-cirrus
CONFIG_SND_SOC_WM8804 \
CONFIG_SND_SOC_WM_ADSP
FILES:= \
+ $(LINUX_DIR)/drivers/mfd/arizona.ko@ge5.15 \
$(LINUX_DIR)/sound/soc/bcm/snd-soc-rpi-cirrus.ko \
$(LINUX_DIR)/sound/soc/codecs/snd-soc-arizona.ko \
$(LINUX_DIR)/sound/soc/codecs/snd-soc-wm-adsp.ko \