summaryrefslogtreecommitdiffstats
path: root/target/linux/bcm27xx
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2020-07-27 12:30:41 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-08-20 14:19:39 +0200
commita14f5bb4bd263c21e103f13279d0c2ff03e48fe5 (patch)
tree18eecef0be1356f014d81b0427471ae18c8839c2 /target/linux/bcm27xx
parentcc75344044e5c16cd4994d824db5779a5ac057c2 (diff)
downloadopenwrt-a14f5bb4bd263c21e103f13279d0c2ff03e48fe5.tar.gz
openwrt-a14f5bb4bd263c21e103f13279d0c2ff03e48fe5.tar.bz2
openwrt-a14f5bb4bd263c21e103f13279d0c2ff03e48fe5.zip
treewide: use wpad-basic-wolfssl as default
In order to support SAE/WPA3-Personal in default images. Replace almost all occurencies of wpad-basic and wpad-mini with wpad-basic-wolfssl for consistency. Keep out ar71xx from the list as it won't be in the next release and would only make backports harder. Build-tested (build-bot settings): ath79: generic, ramips: mt7620/mt76x8/rt305x, lantiq: xrx200/xway, sunxi: a53 Signed-off-by: Petr Štetiar <ynezz@true.cz> [rebase, extend commit message] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/bcm27xx')
-rw-r--r--target/linux/bcm27xx/image/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/bcm27xx/image/Makefile b/target/linux/bcm27xx/image/Makefile
index 2b97593c9a..f009b997e9 100644
--- a/target/linux/bcm27xx/image/Makefile
+++ b/target/linux/bcm27xx/image/Makefile
@@ -79,7 +79,7 @@ define Device/rpi
DEVICE_PACKAGES := \
cypress-firmware-43430-sdio \
cypress-nvram-43430-sdio-rpi-zero-w \
- kmod-brcmfmac wpad-basic
+ kmod-brcmfmac wpad-basic-wolfssl
endef
ifeq ($(SUBTARGET),bcm2708)
TARGET_DEVICES += rpi
@@ -103,7 +103,7 @@ define Device/rpi-2
cypress-nvram-43430-sdio-rpi-3b \
cypress-firmware-43455-sdio \
cypress-nvram-43455-sdio-rpi-3b-plus cypress-nvram-43455-sdio-rpi-4b \
- kmod-brcmfmac wpad-basic
+ kmod-brcmfmac wpad-basic-wolfssl
IMAGE/sysupgrade.img.gz := boot-common | boot-2708 | boot-2711 | sdcard-img | gzip | append-metadata
IMAGE/factory.img.gz := boot-common | boot-2708 | boot-2711 | sdcard-img | gzip
endef
@@ -128,7 +128,7 @@ define Device/rpi-3
cypress-nvram-43430-sdio-rpi-3b \
cypress-firmware-43455-sdio \
cypress-nvram-43455-sdio-rpi-3b-plus \
- kmod-brcmfmac wpad-basic
+ kmod-brcmfmac wpad-basic-wolfssl
endef
ifeq ($(SUBTARGET),bcm2710)
TARGET_DEVICES += rpi-3
@@ -143,7 +143,7 @@ define Device/rpi-4
DEVICE_PACKAGES := \
cypress-firmware-43455-sdio \
cypress-nvram-43455-sdio-rpi-4b \
- kmod-brcmfmac wpad-basic
+ kmod-brcmfmac wpad-basic-wolfssl
IMAGE/sysupgrade.img.gz := boot-common | boot-2711 | sdcard-img | gzip | append-metadata
IMAGE/factory.img.gz := boot-common | boot-2711 | sdcard-img | gzip
endef