summaryrefslogtreecommitdiffstats
path: root/target/linux/bmips
diff options
context:
space:
mode:
authorÁlvaro Fernández Rojas <noltari@gmail.com>2023-05-30 20:02:52 +0200
committerÁlvaro Fernández Rojas <noltari@gmail.com>2023-05-30 20:55:12 +0200
commit959d3f0582d800bf803cee3edffc82bf006a7543 (patch)
tree70e3e628165631f0d8a1dc2063a237ccfebd264c /target/linux/bmips
parenta937eef305ca3ce0bb945185f3c2914478f14c4a (diff)
downloadopenwrt-959d3f0582d800bf803cee3edffc82bf006a7543.tar.gz
openwrt-959d3f0582d800bf803cee3edffc82bf006a7543.tar.bz2
openwrt-959d3f0582d800bf803cee3edffc82bf006a7543.zip
bmips: 6.1: refresh kernel patches
Refresh kernel patches for version 6.1. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Diffstat (limited to 'target/linux/bmips')
-rw-r--r--target/linux/bmips/patches-6.1/100-irqchip-add-support-for-bcm6345-style-external-inter.patch2
-rw-r--r--target/linux/bmips/patches-6.1/200-mips-bmips-automatically-detect-CPU-frequency.patch4
-rw-r--r--target/linux/bmips/patches-6.1/201-mips-bmips-automatically-detect-RAM-size.patch12
-rw-r--r--target/linux/bmips/patches-6.1/202-mips-bmips-tweak-Kconfig-options.patch33
-rw-r--r--target/linux/bmips/patches-6.1/210-revert-macronix-nand-block-protection.patch (renamed from target/linux/bmips/patches-6.1/210-macronix_nand_block_protection_support.patch)0
-rw-r--r--target/linux/bmips/patches-6.1/600-mips-bmips-add-pci-support.patch20
-rw-r--r--target/linux/bmips/patches-6.1/601-pci-controllers-add-bcm6328-pcie-support.patch2
-rw-r--r--target/linux/bmips/patches-6.1/700-leds-add-support-for-Sercomm-MSP430-LED-controller.patch4
8 files changed, 51 insertions, 26 deletions
diff --git a/target/linux/bmips/patches-6.1/100-irqchip-add-support-for-bcm6345-style-external-inter.patch b/target/linux/bmips/patches-6.1/100-irqchip-add-support-for-bcm6345-style-external-inter.patch
index 44cdb068f9..15d44b34d1 100644
--- a/target/linux/bmips/patches-6.1/100-irqchip-add-support-for-bcm6345-style-external-inter.patch
+++ b/target/linux/bmips/patches-6.1/100-irqchip-add-support-for-bcm6345-style-external-inter.patch
@@ -63,7 +63,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
select GENERIC_IRQ_CHIP
--- a/drivers/irqchip/Makefile
+++ b/drivers/irqchip/Makefile
-@@ -62,6 +62,7 @@ obj-$(CONFIG_XTENSA_MX) += irq-xtensa-
+@@ -63,6 +63,7 @@ obj-$(CONFIG_XTENSA_MX) += irq-xtensa-
obj-$(CONFIG_XILINX_INTC) += irq-xilinx-intc.o
obj-$(CONFIG_IRQ_CROSSBAR) += irq-crossbar.o
obj-$(CONFIG_SOC_VF610) += irq-vf610-mscm-ir.o
diff --git a/target/linux/bmips/patches-6.1/200-mips-bmips-automatically-detect-CPU-frequency.patch b/target/linux/bmips/patches-6.1/200-mips-bmips-automatically-detect-CPU-frequency.patch
index e2b73e6ac4..df553f002e 100644
--- a/target/linux/bmips/patches-6.1/200-mips-bmips-automatically-detect-CPU-frequency.patch
+++ b/target/linux/bmips/patches-6.1/200-mips-bmips-automatically-detect-CPU-frequency.patch
@@ -15,7 +15,7 @@ Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
--- a/arch/mips/bmips/setup.c
+++ b/arch/mips/bmips/setup.c
-@@ -31,13 +31,52 @@
+@@ -32,13 +32,52 @@
#define RELO_NORMAL_VEC BIT(18)
@@ -68,7 +68,7 @@ Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
struct bmips_quirk {
const char *compatible;
void (*quirk_fn)(void);
-@@ -142,17 +181,161 @@ const char *get_system_type(void)
+@@ -154,17 +193,161 @@ const char *get_system_type(void)
return "Generic BMIPS kernel";
}
diff --git a/target/linux/bmips/patches-6.1/201-mips-bmips-automatically-detect-RAM-size.patch b/target/linux/bmips/patches-6.1/201-mips-bmips-automatically-detect-RAM-size.patch
index c0bdb0d5ce..68afc39930 100644
--- a/target/linux/bmips/patches-6.1/201-mips-bmips-automatically-detect-RAM-size.patch
+++ b/target/linux/bmips/patches-6.1/201-mips-bmips-automatically-detect-RAM-size.patch
@@ -23,7 +23,7 @@ Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
#include <asm/addrspace.h>
#include <asm/bmips.h>
#include <asm/bootinfo.h>
-@@ -34,13 +35,16 @@
+@@ -35,13 +36,16 @@
#define REG_BCM6318_SOB ((void __iomem *)CKSEG1ADDR(0x10000900))
#define BCM6318_FREQ_SHIFT 23
#define BCM6318_FREQ_MASK (0x3 << BCM6318_FREQ_SHIFT)
@@ -40,7 +40,7 @@ Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
#define REG_BCM6358_DDR_PLLC ((void __iomem *)0xfffe12b8)
#define BCM6358_PLLC_M1_SHIFT 0
#define BCM6358_PLLC_M1_MASK (0xff << BCM6358_PLLC_M1_SHIFT)
-@@ -52,7 +56,9 @@
+@@ -53,7 +57,9 @@
#define REG_BCM6362_MISC_SB ((void __iomem *)CKSEG1ADDR(0x10001814))
#define BCM6362_FCVO_SHIFT 1
#define BCM6362_FCVO_MASK (0x1f << BCM6362_FCVO_SHIFT)
@@ -50,7 +50,7 @@ Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
#define REG_BCM6368_DDR_PLLC ((void __iomem *)CKSEG1ADDR(0x100012a0))
#define BCM6368_PLLC_P1_SHIFT 0
#define BCM6368_PLLC_P1_MASK (0xf << BCM6368_PLLC_P1_SHIFT)
-@@ -67,6 +73,21 @@
+@@ -68,6 +74,21 @@
#define REG_BCM63268_MISC_SB ((void __iomem *)CKSEG1ADDR(0x10001814))
#define BCM63268_FCVO_SHIFT 21
#define BCM63268_FCVO_MASK (0xf << BCM63268_FCVO_SHIFT)
@@ -72,7 +72,7 @@ Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
extern bool bmips_rac_flush_disable;
-@@ -77,6 +98,11 @@ struct bmips_cpufreq {
+@@ -78,6 +99,11 @@ struct bmips_cpufreq {
u32 (*cpu_freq)(void);
};
@@ -84,7 +84,7 @@ Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
struct bmips_quirk {
const char *compatible;
void (*quirk_fn)(void);
-@@ -340,9 +366,90 @@ void __init plat_time_init(void)
+@@ -352,9 +378,90 @@ void __init plat_time_init(void)
mips_hpt_frequency = freq;
}
@@ -175,7 +175,7 @@ Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
const struct bmips_quirk *q;
set_io_port_base(0);
-@@ -360,6 +467,18 @@ void __init plat_mem_setup(void)
+@@ -372,6 +479,18 @@ void __init plat_mem_setup(void)
__dt_setup_arch(dtb);
diff --git a/target/linux/bmips/patches-6.1/202-mips-bmips-tweak-Kconfig-options.patch b/target/linux/bmips/patches-6.1/202-mips-bmips-tweak-Kconfig-options.patch
index c39df850a0..3e0c67d9a4 100644
--- a/target/linux/bmips/patches-6.1/202-mips-bmips-tweak-Kconfig-options.patch
+++ b/target/linux/bmips/patches-6.1/202-mips-bmips-tweak-Kconfig-options.patch
@@ -13,7 +13,7 @@ Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
--- a/arch/mips/Kconfig
+++ b/arch/mips/Kconfig
-@@ -274,25 +274,20 @@ config BMIPS_GENERIC
+@@ -272,19 +272,13 @@ config BMIPS_GENERIC
select SYNC_R4K
select COMMON_CLK
select BCM6345_L1_IRQ
@@ -33,10 +33,35 @@ Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
select SWAP_IO_SPACE
select USB_EHCI_BIG_ENDIAN_DESC if CPU_BIG_ENDIAN
select USB_EHCI_BIG_ENDIAN_MMIO if CPU_BIG_ENDIAN
- select USB_OHCI_BIG_ENDIAN_DESC if CPU_BIG_ENDIAN
- select USB_OHCI_BIG_ENDIAN_MMIO if CPU_BIG_ENDIAN
- select HARDIRQS_SW_RESEND
+@@ -294,6 +288,7 @@ config BMIPS_GENERIC
+ select HAVE_PCI
+ select PCI_DRIVERS_GENERIC
+ select FW_CFE
+ select MIPS_L1_CACHE_SHIFT_4
help
Build a generic DT-based kernel image that boots on select
BCM33xx cable modem chips, BCM63xx DSL chips, and BCM7xxx set-top
+--- a/drivers/irqchip/Kconfig 2023-05-30 19:59:04.671531242 +0200
++++ b/drivers/irqchip/Kconfig 2023-05-30 19:59:55.203880697 +0200
+@@ -121,7 +121,6 @@ config BCM6345_L1_IRQ
+ config BCM7038_L1_IRQ
+ tristate "Broadcom STB 7038-style L1/L2 interrupt controller driver"
+ depends on ARCH_BRCMSTB || BMIPS_GENERIC
+- default ARCH_BRCMSTB || BMIPS_GENERIC
+ select GENERIC_IRQ_CHIP
+ select IRQ_DOMAIN
+ select GENERIC_IRQ_EFFECTIVE_AFF_MASK if SMP
+@@ -129,14 +128,12 @@ config BCM7038_L1_IRQ
+ config BCM7120_L2_IRQ
+ tristate "Broadcom STB 7120-style L2 interrupt controller driver"
+ depends on ARCH_BRCMSTB || BMIPS_GENERIC
+- default ARCH_BRCMSTB || BMIPS_GENERIC
+ select GENERIC_IRQ_CHIP
+ select IRQ_DOMAIN
+
+ config BRCMSTB_L2_IRQ
+ tristate "Broadcom STB generic L2 interrupt controller driver"
+ depends on ARCH_BCM2835 || ARCH_BRCMSTB || BMIPS_GENERIC
+- default ARCH_BCM2835 || ARCH_BRCMSTB || BMIPS_GENERIC
+ select GENERIC_IRQ_CHIP
+ select IRQ_DOMAIN
diff --git a/target/linux/bmips/patches-6.1/210-macronix_nand_block_protection_support.patch b/target/linux/bmips/patches-6.1/210-revert-macronix-nand-block-protection.patch
index 25a16084ef..25a16084ef 100644
--- a/target/linux/bmips/patches-6.1/210-macronix_nand_block_protection_support.patch
+++ b/target/linux/bmips/patches-6.1/210-revert-macronix-nand-block-protection.patch
diff --git a/target/linux/bmips/patches-6.1/600-mips-bmips-add-pci-support.patch b/target/linux/bmips/patches-6.1/600-mips-bmips-add-pci-support.patch
index 36b09105b7..f28dda908d 100644
--- a/target/linux/bmips/patches-6.1/600-mips-bmips-add-pci-support.patch
+++ b/target/linux/bmips/patches-6.1/600-mips-bmips-add-pci-support.patch
@@ -10,21 +10,21 @@ Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
---
arch/mips/Kconfig | 1 +
arch/mips/pci/Makefile | 1 +
- 2 files changed, 2 insertions(+)
+ 2 files changed, 1 insertions(+), 1 deletions(-)
--- a/arch/mips/Kconfig
+++ b/arch/mips/Kconfig
-@@ -274,6 +274,7 @@ config BMIPS_GENERIC
- select SYNC_R4K
- select COMMON_CLK
- select BCM6345_L1_IRQ
-+ select HAVE_PCI
- select IRQ_MIPS_CPU
- select DMA_NONCOHERENT
- select SYS_SUPPORTS_32BIT_KERNEL
+@@ -286,7 +286,6 @@ config BMIPS_GENERIC
+ select USB_OHCI_BIG_ENDIAN_MMIO if CPU_BIG_ENDIAN
+ select HARDIRQS_SW_RESEND
+ select HAVE_PCI
+- select PCI_DRIVERS_GENERIC
+ select FW_CFE
+ select MIPS_L1_CACHE_SHIFT_4
+ help
--- a/arch/mips/pci/Makefile
+++ b/arch/mips/pci/Makefile
-@@ -28,6 +28,7 @@ obj-$(CONFIG_PCI_XTALK_BRIDGE) += pci-xt
+@@ -26,6 +26,7 @@ obj-$(CONFIG_PCI_XTALK_BRIDGE) += pci-xt
# These are still pretty much in the old state, watch, go blind.
#
obj-$(CONFIG_ATH79) += fixup-ath79.o
diff --git a/target/linux/bmips/patches-6.1/601-pci-controllers-add-bcm6328-pcie-support.patch b/target/linux/bmips/patches-6.1/601-pci-controllers-add-bcm6328-pcie-support.patch
index c976430fd5..0eb973ce30 100644
--- a/target/linux/bmips/patches-6.1/601-pci-controllers-add-bcm6328-pcie-support.patch
+++ b/target/linux/bmips/patches-6.1/601-pci-controllers-add-bcm6328-pcie-support.patch
@@ -24,7 +24,7 @@ Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
+ depends on OF
+
config PCI_MVEBU
- bool "Marvell EBU PCIe controller"
+ tristate "Marvell EBU PCIe controller"
depends on ARCH_MVEBU || ARCH_DOVE || COMPILE_TEST
--- a/drivers/pci/controller/Makefile
+++ b/drivers/pci/controller/Makefile
diff --git a/target/linux/bmips/patches-6.1/700-leds-add-support-for-Sercomm-MSP430-LED-controller.patch b/target/linux/bmips/patches-6.1/700-leds-add-support-for-Sercomm-MSP430-LED-controller.patch
index 8b91cac173..ca3c5c7489 100644
--- a/target/linux/bmips/patches-6.1/700-leds-add-support-for-Sercomm-MSP430-LED-controller.patch
+++ b/target/linux/bmips/patches-6.1/700-leds-add-support-for-Sercomm-MSP430-LED-controller.patch
@@ -17,7 +17,7 @@ Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
--- a/drivers/leds/Kconfig
+++ b/drivers/leds/Kconfig
-@@ -288,6 +288,15 @@ config LEDS_COBALT_RAQ
+@@ -281,6 +281,15 @@ config LEDS_COBALT_RAQ
help
This option enables support for the Cobalt Raq series LEDs.
@@ -35,7 +35,7 @@ Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
depends on LEDS_CLASS
--- a/drivers/leds/Makefile
+++ b/drivers/leds/Makefile
-@@ -77,6 +77,7 @@ obj-$(CONFIG_LEDS_PWM) += leds-pwm.o
+@@ -76,6 +76,7 @@ obj-$(CONFIG_LEDS_PWM) += leds-pwm.o
obj-$(CONFIG_LEDS_REGULATOR) += leds-regulator.o
obj-$(CONFIG_LEDS_S3C24XX) += leds-s3c24xx.o
obj-$(CONFIG_LEDS_SC27XX_BLTC) += leds-sc27xx-bltc.o