summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708/image/Makefile
diff options
context:
space:
mode:
authorÁlvaro Fernández Rojas <noltari@gmail.com>2016-10-13 19:01:41 +0200
committerÁlvaro Fernández Rojas <noltari@gmail.com>2016-10-13 19:01:41 +0200
commit611399f1f8601835ca2118a548d58f556cf4b0df (patch)
treea4595fffc1c7d8458d1172e5b52889e537dfab66 /target/linux/brcm2708/image/Makefile
parentad51e09fd1301484820a466a49447a34d7504882 (diff)
downloadopenwrt-611399f1f8601835ca2118a548d58f556cf4b0df.tar.gz
openwrt-611399f1f8601835ca2118a548d58f556cf4b0df.tar.bz2
openwrt-611399f1f8601835ca2118a548d58f556cf4b0df.zip
brcm2708: fix image generation with imagebuilder
COPYING is not present in $(LINUX_DIR) on imagebuilder and prevents a successful image creation. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Diffstat (limited to 'target/linux/brcm2708/image/Makefile')
-rw-r--r--target/linux/brcm2708/image/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/target/linux/brcm2708/image/Makefile b/target/linux/brcm2708/image/Makefile
index f19f57cb2c..d0222df065 100644
--- a/target/linux/brcm2708/image/Makefile
+++ b/target/linux/brcm2708/image/Makefile
@@ -12,6 +12,10 @@ include $(INCLUDE_DIR)/host.mk
FAT32_BLOCK_SIZE=1024
FAT32_BLOCKS=$(shell echo $$(($(CONFIG_BRCM2708_SD_BOOT_PARTSIZE)*1024*1024/$(FAT32_BLOCK_SIZE))))
+define Build/Compile
+ $(CP) $(LINUX_DIR)/COPYING $(KDIR)/COPYING.linux
+endef
+
### Image scripts ###
define Build/kernel-img
perl $(LINUX_DIR)/scripts/mkknlimg $@ $@.tmp
@@ -21,7 +25,7 @@ endef
define Build/boot-img
rm -f $@.boot
mkfs.fat -C $@.boot $(FAT32_BLOCKS)
- mcopy -i $@.boot $(LINUX_DIR)/COPYING ::COPYING.linux
+ mcopy -i $@.boot $(KDIR)/COPYING.linux ::
mcopy -i $@.boot $(KDIR)/bootcode.bin ::
mcopy -i $@.boot $(KDIR)/LICENCE.broadcom ::
mcopy -i $@.boot $(KDIR)/start.elf ::