summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708/image/Makefile
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2017-12-17 15:18:48 +0100
committerÁlvaro Fernández Rojas <noltari@gmail.com>2017-12-25 12:19:41 +0100
commit6f041288927b6b7f64a7ee2a2b2df1d5dcd91990 (patch)
treef6daee9eecdb6b35eec426278a48dc3b409e7668 /target/linux/brcm2708/image/Makefile
parent778543dab4e71c29b69a38aaefb567b05b54eec6 (diff)
downloadopenwrt-6f041288927b6b7f64a7ee2a2b2df1d5dcd91990.tar.gz
openwrt-6f041288927b6b7f64a7ee2a2b2df1d5dcd91990.tar.bz2
openwrt-6f041288927b6b7f64a7ee2a2b2df1d5dcd91990.zip
brcm2708: convert to dt-based board-detection
Use the values populated by the generic board detect function. The first compatible from the device tree source file will be the board name in userspace. The model property from the device tree source file will be the model name. Change the board name where used in the userspace and drop the target specific board detect, to use the generic one. Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'target/linux/brcm2708/image/Makefile')
-rw-r--r--target/linux/brcm2708/image/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/brcm2708/image/Makefile b/target/linux/brcm2708/image/Makefile
index 41730b6803..9ea9a07a9d 100644
--- a/target/linux/brcm2708/image/Makefile
+++ b/target/linux/brcm2708/image/Makefile
@@ -57,7 +57,7 @@ endef
define Device/rpi
DEVICE_TITLE := Raspberry Pi B/B+/CM/Zero/ZeroW
DEVICE_DTS := bcm2708-rpi-b bcm2708-rpi-b-plus bcm2708-rpi-cm bcm2708-rpi-0-w
- SUPPORTED_DEVICES := rpi-b rpi-b-plus rpi-cm rpi-zero-w
+ SUPPORTED_DEVICES := rpi-b rpi-b-plus rpi-cm rpi-zero rpi-zero-w raspberrypi,model-b raspberrypi,model-b-plus raspberrypi,compute-module-1 raspberrypi,model-b-rev2 raspberrypi,model-zero raspberrypi,model-zero-w
endef
ifeq ($(SUBTARGET),bcm2708)
TARGET_DEVICES += rpi
@@ -66,7 +66,7 @@ endif
define Device/rpi-2
DEVICE_TITLE := Raspberry Pi 2B/3B/3CM
DEVICE_DTS := bcm2709-rpi-2-b bcm2710-rpi-3-b bcm2710-rpi-cm3
- SUPPORTED_DEVICES := rpi-2-b rpi-3-b rpi-cm
+ SUPPORTED_DEVICES := rpi-2-b rpi-3-b rpi-cm raspberrypi,2-model-b raspberrypi,3-model-b raspberrypi,compute-module-3
endef
ifeq ($(SUBTARGET),bcm2709)
TARGET_DEVICES += rpi-2
@@ -76,7 +76,7 @@ define Device/rpi-3
KERNEL_IMG := kernel8.img
DEVICE_TITLE := Raspberry Pi 3B (64 bit)
DEVICE_DTS := broadcom/bcm2710-rpi-3-b
- SUPPORTED_DEVICES := rpi-3-b
+ SUPPORTED_DEVICES := rpi-3-b raspberrypi,3-model-b
endef
ifeq ($(SUBTARGET),bcm2710)
TARGET_DEVICES += rpi-3