summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708/image/Makefile
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2018-06-20 11:16:54 +0200
committerDaniel Golle <daniel@makrotopia.org>2018-06-20 11:19:26 +0200
commit969fe206bdb910789bebd064d4b3be00238b0012 (patch)
treeaf647fa88adc68a47bde034e9dbe983a614b6485 /target/linux/brcm2708/image/Makefile
parentdcc942e66685b3ec51906c51b005895f967169b7 (diff)
downloadopenwrt-969fe206bdb910789bebd064d4b3be00238b0012.tar.gz
openwrt-969fe206bdb910789bebd064d4b3be00238b0012.tar.bz2
openwrt-969fe206bdb910789bebd064d4b3be00238b0012.zip
brcm2708: Add wifi driver, firmware and NVRAM for RPi1
Apparently there are RPi1 devices with BRCM43430 wifi, such as the Pi Zero W. Add the necessary packages for that to the image generated for those boards as well. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'target/linux/brcm2708/image/Makefile')
-rw-r--r--target/linux/brcm2708/image/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/linux/brcm2708/image/Makefile b/target/linux/brcm2708/image/Makefile
index 69c1d83fbf..456570cdec 100644
--- a/target/linux/brcm2708/image/Makefile
+++ b/target/linux/brcm2708/image/Makefile
@@ -57,6 +57,7 @@ define Device/rpi
DEVICE_TITLE := Raspberry Pi B/B+/CM/Zero/ZeroW
DEVICE_DTS := bcm2708-rpi-b bcm2708-rpi-b-plus bcm2708-rpi-cm bcm2708-rpi-0-w
SUPPORTED_DEVICES := rpi-b rpi-b-plus rpi-cm rpi-zero rpi-zero-w raspberrypi,model-b raspberrypi,model-b-plus raspberrypi,compute-module-1 raspberrypi,model-b-rev2 raspberrypi,model-zero raspberrypi,model-zero-w
+ DEVICE_PACKAGES := brcmfmac-firmware-43430-sdio brcmfmac-board-rpi2 kmod-brcmfmac wpad-mini
endef
ifeq ($(SUBTARGET),bcm2708)
TARGET_DEVICES += rpi