summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708
diff options
context:
space:
mode:
authorKoen Vandeputte <koen.vandeputte@ncentric.com>2019-11-25 11:32:08 +0100
committerKoen Vandeputte <koen.vandeputte@ncentric.com>2019-11-29 09:59:49 +0100
commitf19e471f3206d0b5885490e52972085d2da2a10b (patch)
treed57ce28632cc05db523fe9c1d8f85f9c2953e5c1 /target/linux/brcm2708
parent414b7c107aaa0e037b3f352e0650bbc429db41a7 (diff)
downloadopenwrt-f19e471f3206d0b5885490e52972085d2da2a10b.tar.gz
openwrt-f19e471f3206d0b5885490e52972085d2da2a10b.tar.bz2
openwrt-f19e471f3206d0b5885490e52972085d2da2a10b.zip
kernel: bump 4.19 to 4.19.86
Refreshed all patches. Altered patches: - 950-0064-mfd-Add-Raspberry-Pi-Sense-HAT-core-driver.patch - 0005-mtd-physmap_of-Move-custom-initialization.patch Remove upstreamed: - 0001-pinctrl-gemini-Mask-and-set-properly.patch - 0002-pinctrl-gemini-Fix-up-TVC-clock-group.patch Compile-tested on: cns3xxx Runtime-tested on: cns3xxx Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
Diffstat (limited to 'target/linux/brcm2708')
-rw-r--r--target/linux/brcm2708/patches-4.19/950-0041-bcm2708-framebuffer-driver.patch2
-rw-r--r--target/linux/brcm2708/patches-4.19/950-0064-mfd-Add-Raspberry-Pi-Sense-HAT-core-driver.patch9
2 files changed, 7 insertions, 4 deletions
diff --git a/target/linux/brcm2708/patches-4.19/950-0041-bcm2708-framebuffer-driver.patch b/target/linux/brcm2708/patches-4.19/950-0041-bcm2708-framebuffer-driver.patch
index c019bc8271..7135ff3fcf 100644
--- a/target/linux/brcm2708/patches-4.19/950-0041-bcm2708-framebuffer-driver.patch
+++ b/target/linux/brcm2708/patches-4.19/950-0041-bcm2708-framebuffer-driver.patch
@@ -93,7 +93,7 @@ Signed-off-by: James Hughes <james.hughes@raspberrypi.org>
--- a/drivers/video/fbdev/Kconfig
+++ b/drivers/video/fbdev/Kconfig
-@@ -236,6 +236,20 @@ config FB_TILEBLITTING
+@@ -242,6 +242,20 @@ config FB_TILEBLITTING
comment "Frame buffer hardware drivers"
depends on FB
diff --git a/target/linux/brcm2708/patches-4.19/950-0064-mfd-Add-Raspberry-Pi-Sense-HAT-core-driver.patch b/target/linux/brcm2708/patches-4.19/950-0064-mfd-Add-Raspberry-Pi-Sense-HAT-core-driver.patch
index 00228d6434..1a8ab6c44e 100644
--- a/target/linux/brcm2708/patches-4.19/950-0064-mfd-Add-Raspberry-Pi-Sense-HAT-core-driver.patch
+++ b/target/linux/brcm2708/patches-4.19/950-0064-mfd-Add-Raspberry-Pi-Sense-HAT-core-driver.patch
@@ -390,11 +390,10 @@ Subject: [PATCH 064/806] mfd: Add Raspberry Pi Sense HAT core driver
+
--- a/drivers/video/fbdev/Kconfig
+++ b/drivers/video/fbdev/Kconfig
-@@ -2355,3 +2355,16 @@ config FB_SM712
- This driver is also available as a module. The module will be
+@@ -2350,6 +2350,19 @@ config FB_SM712
called sm712fb. If you want to compile it as a module, say M
here and read <file:Documentation/kbuild/modules.txt>.
-+
+
+config FB_RPISENSE
+ tristate "Raspberry Pi Sense HAT framebuffer"
+ depends on FB
@@ -407,6 +406,10 @@ Subject: [PATCH 064/806] mfd: Add Raspberry Pi Sense HAT core driver
+
+ help
+ This is the framebuffer driver for the Raspberry Pi Sense HAT
++
+ source "drivers/video/fbdev/omap/Kconfig"
+ source "drivers/video/fbdev/omap2/Kconfig"
+ source "drivers/video/fbdev/mmp/Kconfig"
--- a/drivers/video/fbdev/Makefile
+++ b/drivers/video/fbdev/Makefile
@@ -138,6 +138,7 @@ obj-$(CONFIG_FB_DA8XX) += da8xx-fb.o