summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm47xx/image/Makefile
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2010-12-02 21:27:54 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2010-12-02 21:27:54 +0000
commit41b3383499e1ba10c49d77dd0526f1a045128f97 (patch)
tree660b1ad6a7d8aadc9ac67e3b15dcfde56c0725cc /target/linux/brcm47xx/image/Makefile
parent4482f4b5f127fbccfc9771d68617bffd47b49a27 (diff)
downloadopenwrt-41b3383499e1ba10c49d77dd0526f1a045128f97.tar.gz
openwrt-41b3383499e1ba10c49d77dd0526f1a045128f97.tar.bz2
openwrt-41b3383499e1ba10c49d77dd0526f1a045128f97.zip
brcm47xx: Add edimax PS1208mfg support
Thank you clemvangelis for the patches. (closes #7672) SVN-Revision: 24217
Diffstat (limited to 'target/linux/brcm47xx/image/Makefile')
-rw-r--r--target/linux/brcm47xx/image/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/target/linux/brcm47xx/image/Makefile b/target/linux/brcm47xx/image/Makefile
index f8c09b97d4..034200c50a 100644
--- a/target/linux/brcm47xx/image/Makefile
+++ b/target/linux/brcm47xx/image/Makefile
@@ -49,6 +49,10 @@ define Image/Build/USR
$(STAGING_DIR_HOST)/bin/trx2usr $(BIN_DIR)/$(IMG_PREFIX)-$(1).trx $(BIN_DIR)/openwrt-$(2)-$(3).bin
endef
+define Image/Build/Edi
+ $(STAGING_DIR_HOST)/bin/trx2edips $(BIN_DIR)/$(IMG_PREFIX)-$(1).trx $(BIN_DIR)/openwrt-$(2)-$(3).bin
+endef
+
define trxalign/jffs2-128k
-a 0x20000 -f $(KDIR)/root.$(1)
endef
@@ -87,6 +91,7 @@ define Image/Build/jffs2-64k
$(call Image/Build/CyberTAN,$(1),wrt350n_v1,EWCG,1.04.1,$(patsubst jffs2-%,jffs2,$(1)))
$(call Image/Build/Motorola,$(1),wa840g,2,$(patsubst jffs2-%,jffs2,$(1)))
$(call Image/Build/Motorola,$(1),we800g,3,$(patsubst jffs2-%,jffs2,$(1)))
+ $(call Image/Build/Edi,$(1),ps1208mfg,$(patsubst jffs2-%,jffs2,$(1)))
endef
define Image/Build/squashfs