summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.9/700-swconfig.patch
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2013-03-14 14:45:56 +0000
committerFlorian Fainelli <florian@openwrt.org>2013-03-14 14:45:56 +0000
commitb2e63b8ea81fae72aef69649631cf491bac5306f (patch)
tree9a4bc7d83c339b4b842999287e3ae5e5d5d6734a /target/linux/generic/patches-3.9/700-swconfig.patch
parent32f3b1e3582701ef6c8c248b9ad0a761c42bbc1b (diff)
downloadopenwrt-b2e63b8ea81fae72aef69649631cf491bac5306f.tar.gz
openwrt-b2e63b8ea81fae72aef69649631cf491bac5306f.tar.bz2
openwrt-b2e63b8ea81fae72aef69649631cf491bac5306f.zip
kernel: add support for 3.9-rc2
Signed-off-by: Florian Fainelli <florian@openwrt.org> SVN-Revision: 36008
Diffstat (limited to 'target/linux/generic/patches-3.9/700-swconfig.patch')
-rw-r--r--target/linux/generic/patches-3.9/700-swconfig.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.9/700-swconfig.patch b/target/linux/generic/patches-3.9/700-swconfig.patch
new file mode 100644
index 0000000000..0b20d64012
--- /dev/null
+++ b/target/linux/generic/patches-3.9/700-swconfig.patch
@@ -0,0 +1,39 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -12,6 +12,16 @@ menuconfig PHYLIB
+
+ if PHYLIB
+
++config SWCONFIG
++ tristate "Switch configuration API"
++ ---help---
++ Switch configuration API using netlink. This allows
++ you to configure the VLAN features of certain switches.
++
++config SWCONFIG_LEDS
++ bool "Switch LED trigger support"
++ depends on (SWCONFIG && LEDS_TRIGGERS)
++
+ comment "MII PHY device drivers"
+
+ config AT803X_PHY
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -3,6 +3,7 @@
+ libphy-objs := phy.o phy_device.o mdio_bus.o
+
+ obj-$(CONFIG_PHYLIB) += libphy.o
++obj-$(CONFIG_SWCONFIG) += swconfig.o
+ obj-$(CONFIG_MARVELL_PHY) += marvell.o
+ obj-$(CONFIG_DAVICOM_PHY) += davicom.o
+ obj-$(CONFIG_CICADA_PHY) += cicada.o
+--- a/include/uapi/linux/Kbuild
++++ b/include/uapi/linux/Kbuild
+@@ -358,6 +358,7 @@ header-y += stddef.h
+ header-y += string.h
+ header-y += suspend_ioctls.h
+ header-y += swab.h
++header-y += switch.h
+ header-y += synclink.h
+ header-y += sysctl.h
+ header-y += sysinfo.h