summaryrefslogtreecommitdiffstats
path: root/target/linux/imx6
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2018-11-23 10:54:25 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2018-11-25 19:23:03 +0100
commit82b34c1f6082e15347b80ff0aa1040e5f309d382 (patch)
tree2f71290650e07bbee0c0c2ffa3fd208aa3e5b65f /target/linux/imx6
parent09eac6d13f527ffaf49fdcd8b14a0015a66e002d (diff)
downloadopenwrt-82b34c1f6082e15347b80ff0aa1040e5f309d382.tar.gz
openwrt-82b34c1f6082e15347b80ff0aa1040e5f309d382.tar.bz2
openwrt-82b34c1f6082e15347b80ff0aa1040e5f309d382.zip
imx6: image: ventana: Add missing BOOT_SCRIPT variable
This is probably theoretical problem as the Ventana is defined first in the image Makefile, but once the position of the definition would change in the future (alphabetical sorting?) it would get bootscript from the previous board which would have BOOT_SCRIPT set. Cc: Tim Harvey <tharvey@gateworks.com> Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'target/linux/imx6')
-rw-r--r--target/linux/imx6/image/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/linux/imx6/image/Makefile b/target/linux/imx6/image/Makefile
index f13412f1e3..9dd5b520a1 100644
--- a/target/linux/imx6/image/Makefile
+++ b/target/linux/imx6/image/Makefile
@@ -136,6 +136,7 @@ define Device/ventana
IMAGES := nand.ubi bootfs.tar.gz
IMAGE_NAME = $$(IMAGE_PREFIX)-$$(1).$$(2)
UBINIZE_PARTS = boot=$$(KDIR_KERNEL_IMAGE).boot.ubifs=15
+ BOOT_SCRIPT := bootscript-ventana
IMAGE/nand.ubi := append-ubi
IMAGE/bootfs.tar.gz := bootfs.tar.gz | install-dtb
IMAGE_NAME = $$(IMAGE_PREFIX)-$$(1)-$$(2)