summaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2018-09-05 14:51:44 +0200
committerJohn Crispin <john@phrozen.org>2018-09-26 16:39:44 +0200
commit61b5b4971e7d6aab6b0695997c3b5aaf73c53b5f (patch)
treefb05b3965b058d80e90e3a2d567da431418a401d /target/linux/ipq806x
parentde1c58a64bd66319e770d2587da07d8c9c90174a (diff)
downloadopenwrt-61b5b4971e7d6aab6b0695997c3b5aaf73c53b5f.tar.gz
openwrt-61b5b4971e7d6aab6b0695997c3b5aaf73c53b5f.tar.bz2
openwrt-61b5b4971e7d6aab6b0695997c3b5aaf73c53b5f.zip
mac80211: make ath10k-ct the default ath10k
We select ath10k-ct by default, but it is still possible to build the upstream version. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> Signed-off-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'target/linux/ipq806x')
-rw-r--r--target/linux/ipq806x/Makefile2
-rw-r--r--target/linux/ipq806x/image/Makefile24
-rw-r--r--target/linux/ipq806x/profiles/00-default.mk2
3 files changed, 14 insertions, 14 deletions
diff --git a/target/linux/ipq806x/Makefile b/target/linux/ipq806x/Makefile
index 13be76e7ba..178bf97915 100644
--- a/target/linux/ipq806x/Makefile
+++ b/target/linux/ipq806x/Makefile
@@ -20,7 +20,7 @@ DEFAULT_PACKAGES += \
kmod-ata-core kmod-ata-ahci kmod-ata-ahci-platform \
kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport \
kmod-usb3 kmod-usb-dwc3-of-simple kmod-usb-phy-qcom-dwc3 \
- kmod-ath10k wpad-mini \
+ kmod-ath10k-ct wpad-mini \
uboot-envtools
$(eval $(call BuildTarget))
diff --git a/target/linux/ipq806x/image/Makefile b/target/linux/ipq806x/image/Makefile
index a7f740ff62..b82d54b0f6 100644
--- a/target/linux/ipq806x/image/Makefile
+++ b/target/linux/ipq806x/image/Makefile
@@ -98,7 +98,7 @@ define Device/linksys_ea8500
IMAGES := factory.bin sysupgrade.bin
IMAGE/factory.bin := append-kernel | pad-to $$$${KERNEL_SIZE} | append-ubi
DEVICE_TITLE := Linksys EA8500
- DEVICE_PACKAGES := ath10k-firmware-qca99x0
+ DEVICE_PACKAGES := ath10k-firmware-qca99x0-ct
endef
TARGET_DEVICES += linksys_ea8500
@@ -110,7 +110,7 @@ define Device/nec_wg2600hp
DEVICE_TITLE := NEC Aterm WG2600HP
IMAGES := sysupgrade.bin
IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
- DEVICE_PACKAGES := ath10k-firmware-qca99x0
+ DEVICE_PACKAGES := ath10k-firmware-qca99x0-ct
endef
TARGET_DEVICES += nec_wg2600hp
@@ -125,7 +125,7 @@ define Device/netgear_d7800
BOARD_NAME := d7800
SUPPORTED_DEVICES += d7800
DEVICE_TITLE := Netgear Nighthawk X4 D7800
- DEVICE_PACKAGES := ath10k-firmware-qca99x0
+ DEVICE_PACKAGES := ath10k-firmware-qca99x0-ct
endef
TARGET_DEVICES += netgear_d7800
@@ -140,7 +140,7 @@ define Device/netgear_r7500
BOARD_NAME := r7500
SUPPORTED_DEVICES += r7500
DEVICE_TITLE := Netgear Nighthawk X4 R7500
- DEVICE_PACKAGES := ath10k-firmware-qca988x
+ DEVICE_PACKAGES := ath10k-firmware-qca988x-ct
endef
TARGET_DEVICES += netgear_r7500
@@ -155,7 +155,7 @@ define Device/netgear_r7500v2
BOARD_NAME := r7500v2
SUPPORTED_DEVICES += r7500v2
DEVICE_TITLE := Netgear Nighthawk X4 R7500v2
- DEVICE_PACKAGES := ath10k-firmware-qca99x0 ath10k-firmware-qca988x
+ DEVICE_PACKAGES := ath10k-firmware-qca99x0-ct ath10k-firmware-qca988x-ct
endef
TARGET_DEVICES += netgear_r7500v2
@@ -170,7 +170,7 @@ define Device/netgear_r7800
BOARD_NAME := r7800
SUPPORTED_DEVICES += r7800
DEVICE_TITLE := Netgear Nighthawk X4S R7800
- DEVICE_PACKAGES := ath10k-firmware-qca9984
+ DEVICE_PACKAGES := ath10k-firmware-qca9984-ct
endef
TARGET_DEVICES += netgear_r7800
@@ -184,7 +184,7 @@ define Device/qcom_ipq8064-ap148
BOARD_NAME := ap148
SUPPORTED_DEVICES += ap148
DEVICE_TITLE := Qualcomm AP148
- DEVICE_PACKAGES := ath10k-firmware-qca99x0
+ DEVICE_PACKAGES := ath10k-firmware-qca99x0-ct
endef
TARGET_DEVICES += qcom_ipq8064-ap148
@@ -197,7 +197,7 @@ define Device/qcom_ipq8064-ap148-legacy
BOARD_NAME := ap148
SUPPORTED_DEVICES := qcom,ipq8064-ap148 ap148
DEVICE_TITLE := Qualcomm AP148 (legacy)
- DEVICE_PACKAGES := ath10k-firmware-qca99x0
+ DEVICE_PACKAGES := ath10k-firmware-qca99x0-ct
endef
TARGET_DEVICES += qcom_ipq8064-ap148-legacy
@@ -207,7 +207,7 @@ define Device/qcom_ipq8064-db149
KERNEL_INSTALL := 1
BOARD_NAME := db149
DEVICE_TITLE := Qualcomm DB149
- DEVICE_PACKAGES := ath10k-firmware-qca99x0
+ DEVICE_PACKAGES := ath10k-firmware-qca99x0-ct
endef
TARGET_DEVICES += qcom_ipq8064-db149
@@ -220,7 +220,7 @@ define Device/tplink_c2600
SUPPORTED_DEVICES += c2600
TPLINK_BOARD_ID := C2600
DEVICE_TITLE := TP-Link Archer C2600
- DEVICE_PACKAGES := ath10k-firmware-qca99x0
+ DEVICE_PACKAGES := ath10k-firmware-qca99x0-ct
endef
TARGET_DEVICES += tplink_c2600
@@ -235,7 +235,7 @@ define Device/tplink_vr2600v
BOARD_NAME := vr2600v
SUPPORTED_DEVICES += vr2600v
DEVICE_TITLE := TP-Link Archer VR2600v
- DEVICE_PACKAGES := ath10k-firmware-qca99x0
+ DEVICE_PACKAGES := ath10k-firmware-qca99x0-ct
IMAGES := sysupgrade.bin
IMAGE/sysupgrade.bin := pad-extra 512 | append-kernel | pad-to $$$${KERNEL_SIZE} | append-rootfs | pad-rootfs | append-metadata
endef
@@ -251,7 +251,7 @@ define Device/zyxel_nbg6817
RAS_VERSION := "V1.99(OWRT.9999)C0"
SUPPORTED_DEVICES += nbg6817
DEVICE_TITLE := ZyXEL NBG6817
- DEVICE_PACKAGES := ath10k-firmware-qca9984 e2fsprogs kmod-fs-ext4 losetup
+ DEVICE_PACKAGES := ath10k-firmware-qca9984-ct e2fsprogs kmod-fs-ext4 losetup
$(call Device/ZyXELImage)
endef
TARGET_DEVICES += zyxel_nbg6817
diff --git a/target/linux/ipq806x/profiles/00-default.mk b/target/linux/ipq806x/profiles/00-default.mk
index 9baa24fa95..ea0c5623f6 100644
--- a/target/linux/ipq806x/profiles/00-default.mk
+++ b/target/linux/ipq806x/profiles/00-default.mk
@@ -1,7 +1,7 @@
define Profile/Default
NAME:=Default Profile
PRIORITY:=1
- PACKAGES:=ath10k-firmware-qca99x0 ath10k-firmware-qca988x ath10k-firmware-qca9984
+ PACKAGES:=ath10k-firmware-qca99x0-ct-ct ath10k-firmware-qca988x-ct-ct ath10k-firmware-qca9984-ct-ct
endef
define Profile/Default/Description