summaryrefslogtreecommitdiffstats
path: root/target/linux/kirkwood/image
diff options
context:
space:
mode:
authorSungbo Eo <mans0n@gorani.run>2022-01-01 21:00:36 +0900
committerSungbo Eo <mans0n@gorani.run>2022-01-29 23:50:28 +0900
commit957f9adeb1f8ec5de8d73e183dec267dbc6dc8bb (patch)
tree44238e23a15f6b0f89f303b1d7b00def6b8f5261 /target/linux/kirkwood/image
parent0c568d044fac166e803ab6a9bcd2f18d31309f9f (diff)
downloadopenwrt-957f9adeb1f8ec5de8d73e183dec267dbc6dc8bb.tar.gz
openwrt-957f9adeb1f8ec5de8d73e183dec267dbc6dc8bb.tar.bz2
openwrt-957f9adeb1f8ec5de8d73e183dec267dbc6dc8bb.zip
kirkwood: add support for ipTIME NAS1
ipTIME NAS1 is a 1-bay NAS, based on Marvell Kirkwood SoC. Specifications: * SoC: 88F6281 * RAM: 256 MiB * Flash: SPI NOR 16 MiB * SATA: 1x 3Gb/s * Ethernet: 1x 1GbE * USB: 1x 2.0 * Fan: 2 speed level * UART: JP1 (115200 8N1) * Pinout: [3V3] (TXD) (RXD) (GND) Notes: * There are several variants of the model name: "NAS-I", "NASI", "NAS1". Here "NAS1" is adopted for consistent naming scheme. * The reset button is also a USB copy button in stock FW, but in this patch the former is the only default behavior. Installation via web interface: 1. Flash sysupgrade image through the stock web interface. Revert to stock firmware: 1. Perform sysupgrade with stock image. Signed-off-by: Sungbo Eo <mans0n@gorani.run>
Diffstat (limited to 'target/linux/kirkwood/image')
-rw-r--r--target/linux/kirkwood/image/Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/target/linux/kirkwood/image/Makefile b/target/linux/kirkwood/image/Makefile
index 4a2ca8d68e..60e8654ad3 100644
--- a/target/linux/kirkwood/image/Makefile
+++ b/target/linux/kirkwood/image/Makefile
@@ -184,6 +184,21 @@ define Device/iom_ix2-200
endef
TARGET_DEVICES += iom_ix2-200
+define Device/iptime_nas1
+ DEVICE_VENDOR := ipTIME
+ DEVICE_MODEL := NAS1
+ DEVICE_PACKAGES := kmod-ata-marvell-sata kmod-fs-ext4 \
+ kmod-gpio-button-hotplug kmod-gpio-pca953x kmod-hwmon-drivetemp \
+ kmod-hwmon-gpiofan kmod-usb-ledtrig-usbport -uboot-envtools
+ KERNEL := $$(KERNEL) | iptime-naspkg nas1
+ BLOCKSIZE := 256k
+ IMAGE_SIZE := 15872k
+ IMAGES := sysupgrade.bin
+ IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | \
+ check-size | append-metadata
+endef
+TARGET_DEVICES += iptime_nas1
+
define Device/linksys
DEVICE_VENDOR := Linksys
DEVICE_PACKAGES := kmod-mwl8k wpad-basic-wolfssl kmod-gpio-button-hotplug