summaryrefslogtreecommitdiffstats
path: root/target/linux/layerscape/Makefile
diff options
context:
space:
mode:
authorYutang Jiang <yutang.jiang@nxp.com>2016-10-29 00:14:32 +0800
committerJohn Crispin <john@phrozen.org>2016-10-31 17:00:10 +0100
commitc6c731fe311f7da42777ffd31804a4f6aa3f8e19 (patch)
treed92c7296f82d46d1b2da30933a97595f6cb8ad66 /target/linux/layerscape/Makefile
parenta34f96d6cf80c7c3c425076714d9c4caa67e3670 (diff)
downloadopenwrt-c6c731fe311f7da42777ffd31804a4f6aa3f8e19.tar.gz
openwrt-c6c731fe311f7da42777ffd31804a4f6aa3f8e19.tar.bz2
openwrt-c6c731fe311f7da42777ffd31804a4f6aa3f8e19.zip
layerscape: add 64b/32b target for ls1043ardb device
Add support for NXP layerscape ls1043ardb 64b/32b Dev board. LS1043a is an SoC with 4x64-bit up to 1.6 GHz ARMv8 A53 cores. ls1043ardb support features as: 2GB DDR4, 128MB NOR/512MB NAND, USB3.0, eSDHC, I2C, GPIO, PCIe/Mini-PCIe, 6x1G/1x10G network port, etc. 64b/32b ls1043ardb target is using 4.4 kernel, and rcw/u-boot/fman images from NXP QorIQ SDK release. All of 4.4 kernel patches porting from SDK release or upstream. QorIQ SDK ISOs can be downloaded from this location: http://www.nxp.com/products/software-and-tools/run-time-software/linux-sdk/linux-sdk-for-qoriq-processors:SDKLINUX Signed-off-by: Yutang Jiang <yutang.jiang@nxp.com>
Diffstat (limited to 'target/linux/layerscape/Makefile')
-rw-r--r--target/linux/layerscape/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/layerscape/Makefile b/target/linux/layerscape/Makefile
new file mode 100644
index 0000000000..f511407f91
--- /dev/null
+++ b/target/linux/layerscape/Makefile
@@ -0,0 +1,26 @@
+#
+# Copyright (C) 2016 Jiang Yutang <jiangyutang1978@gmail.com>
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+BOARD:=layerscape
+BOARDNAME:=NXP Layerscape
+DEVICE_TYPE:=developerboard
+KERNEL_PATCHVER:=4.4
+KERNELNAME:=Image dtbs
+FEATURES:=squashfs nand usb pcie gpio
+SUBTARGETS:=64b 32b
+MAINTAINER:=Jiang Yutang <jiangyutang1978@gmail.com>
+
+include $(INCLUDE_DIR)/target.mk
+
+define Target/Description
+ Build firmware images for $(BOARDNAME) SoC devices.
+endef
+
+DEFAULT_PACKAGES += kmod-usb3 kmod-usb-dwc3 kmod-usb-storage
+
+$(eval $(call BuildTarget))