summaryrefslogtreecommitdiffstats
path: root/target/linux/layerscape
diff options
context:
space:
mode:
authorPawel Dembicki <paweldembicki@gmail.com>2022-10-29 22:59:50 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2022-11-27 13:18:29 +0100
commit5b0e111789314c9ff0f351e3b5d54d43d4485813 (patch)
tree4a1a0e6e12a0cfbbbd2b8dfc35262c3a7146c819 /target/linux/layerscape
parent23b9b01cdd612bfa46620cd505285707b164e891 (diff)
downloadopenwrt-5b0e111789314c9ff0f351e3b5d54d43d4485813.tar.gz
openwrt-5b0e111789314c9ff0f351e3b5d54d43d4485813.tar.bz2
openwrt-5b0e111789314c9ff0f351e3b5d54d43d4485813.zip
layerscape: kmod-ppfe: Use ppfe driver as module
In 8274451cb86 kmod-ppfe was changed to built-in because CONFIG_FSL_PPFE was binary. In 5.10 and 5.15 kernel, PPFE driver can be build as module. This patch switch kmod-ppfe from build-in to loadable module. Loadable module helps to avoid hazard: driver is looking for firmware file before mount root. Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
Diffstat (limited to 'target/linux/layerscape')
-rw-r--r--target/linux/layerscape/armv8_64b/config-5.104
-rw-r--r--target/linux/layerscape/armv8_64b/config-5.154
-rw-r--r--target/linux/layerscape/modules.mk2
3 files changed, 5 insertions, 5 deletions
diff --git a/target/linux/layerscape/armv8_64b/config-5.10 b/target/linux/layerscape/armv8_64b/config-5.10
index 1f4253db89..36ca870618 100644
--- a/target/linux/layerscape/armv8_64b/config-5.10
+++ b/target/linux/layerscape/armv8_64b/config-5.10
@@ -292,8 +292,8 @@ CONFIG_FSL_GUTS=y
CONFIG_FSL_IFC=y
CONFIG_FSL_MC_BUS=y
CONFIG_FSL_MC_DPIO=y
-CONFIG_FSL_PPFE=y
-CONFIG_FSL_PPFE_UTIL_DISABLED=y
+# CONFIG_FSL_PPFE is not set
+# CONFIG_FSL_PPFE_UTIL_DISABLED is not set
# CONFIG_FSL_QMAN_TEST is not set
CONFIG_FSL_RCPM=y
CONFIG_FSL_XGMAC_MDIO=y
diff --git a/target/linux/layerscape/armv8_64b/config-5.15 b/target/linux/layerscape/armv8_64b/config-5.15
index ee807d29f6..e959d4393b 100644
--- a/target/linux/layerscape/armv8_64b/config-5.15
+++ b/target/linux/layerscape/armv8_64b/config-5.15
@@ -293,8 +293,8 @@ CONFIG_FSL_IFC=y
CONFIG_FSL_MC_BUS=y
CONFIG_FSL_MC_DPIO=y
# CONFIG_FSL_MC_UAPI_SUPPORT is not set
-CONFIG_FSL_PPFE=y
-CONFIG_FSL_PPFE_UTIL_DISABLED=y
+# CONFIG_FSL_PPFE is not set
+# CONFIG_FSL_PPFE_UTIL_DISABLED is not set
# CONFIG_FSL_QMAN_TEST is not set
CONFIG_FSL_RCPM=y
CONFIG_FSL_XGMAC_MDIO=y
diff --git a/target/linux/layerscape/modules.mk b/target/linux/layerscape/modules.mk
index 11e75ee749..9aa11e08fb 100644
--- a/target/linux/layerscape/modules.mk
+++ b/target/linux/layerscape/modules.mk
@@ -22,7 +22,7 @@ define KernelPackage/ppfe
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:=Freescale PPFE Driver support
DEPENDS:=@TARGET_layerscape
- KCONFIG:=CONFIG_FSL_PPFE=y \
+ KCONFIG:=CONFIG_FSL_PPFE \
CONFIG_FSL_PPFE_UTIL_DISABLED=y
FILES:=$(LINUX_DIR)/drivers/staging/fsl_ppfe/pfe.ko
AUTOLOAD:=$(call AutoLoad,35,pfe)