summaryrefslogtreecommitdiffstats
path: root/target/linux/mediatek/image/mt7622.mk
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2023-05-26 10:26:49 +0100
committerDaniel Golle <daniel@makrotopia.org>2023-05-26 14:31:36 +0100
commit43d27b02522c100b0c625d4b22f4bb6ad83c166f (patch)
treea0287637eb2c6c97eac539da17684aef42fd3c8e /target/linux/mediatek/image/mt7622.mk
parent911742989a69fee116080265d5052a538e606e58 (diff)
downloadopenwrt-43d27b02522c100b0c625d4b22f4bb6ad83c166f.tar.gz
openwrt-43d27b02522c100b0c625d4b22f4bb6ad83c166f.tar.bz2
openwrt-43d27b02522c100b0c625d4b22f4bb6ad83c166f.zip
mediatek: fix, clean and unify SD card image generation
Make sure sub-images on the SD card are size-checked, allow generating SD card without squashfs and/or initramfs. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'target/linux/mediatek/image/mt7622.mk')
-rw-r--r--target/linux/mediatek/image/mt7622.mk7
1 files changed, 4 insertions, 3 deletions
diff --git a/target/linux/mediatek/image/mt7622.mk b/target/linux/mediatek/image/mt7622.mk
index 12e819ed54..92824ff24a 100644
--- a/target/linux/mediatek/image/mt7622.mk
+++ b/target/linux/mediatek/image/mt7622.mk
@@ -88,9 +88,10 @@ define Device/bananapi_bpi-r64
pad-to 40960k | bl31-uboot bananapi_bpi-r64-emmc |\
pad-to 43008k | bl2 snand-2ddr |\
pad-to 43520k | bl31-uboot bananapi_bpi-r64-snand |\
- $(if $(CONFIG_TARGET_ROOTFS_SQUASHFS),\
- pad-to 46080k | append-image squashfs-sysupgrade.itb | check-size | gzip \
- )
+ $(if $(CONFIG_TARGET_ROOTFS_SQUASHFS), \
+ pad-to 46080k | append-image squashfs-sysupgrade.itb | check-size |\
+ ) \
+ gzip
IMAGE_SIZE := $$(shell expr 45 + $$(CONFIG_TARGET_ROOTFS_PARTSIZE))m
KERNEL := kernel-bin | gzip
KERNEL_INITRAMFS := kernel-bin | lzma | fit lzma $$(DTS_DIR)/$$(DEVICE_DTS).dtb with-initrd | pad-to 128k