summaryrefslogtreecommitdiffstats
path: root/target/linux/mediatek/image/mt7622.mk
diff options
context:
space:
mode:
authorChuanhong Guo <gch981213@gmail.com>2021-08-24 00:18:23 +0800
committerChuanhong Guo <gch981213@gmail.com>2021-09-03 15:53:28 +0800
commit43f0e386d4e79e9014e926d1d9b5e2ff8f1379cb (patch)
tree1b25043b5698dbe997e0ef97d0483e7a5aafb7c4 /target/linux/mediatek/image/mt7622.mk
parent9e9057f4164a31bbe5a645878a9e0f083b533c0f (diff)
downloadopenwrt-43f0e386d4e79e9014e926d1d9b5e2ff8f1379cb.tar.gz
openwrt-43f0e386d4e79e9014e926d1d9b5e2ff8f1379cb.tar.bz2
openwrt-43f0e386d4e79e9014e926d1d9b5e2ff8f1379cb.zip
mediatek: add support for TOTOLINK A8000RU
Specifications: - SoC: MT7622 - RAM: 512MB - Flash: MX35LF1GE4AB 128MB SPI NAND - Ethernet: RTL8367S 5x1GbE - WiFi: 2.4G: MT7622 5G: MT7615N x2 - Other ports: USB3.0 x1 Flash instruction: *important*: upgrade vendor firmware to at least V7.1cu.643_B20200521 1. hold the reset button and power on the device. wait for about 10s before releasing the reset button. 2. upload sysupgrade.bin via u-boot recovery page on http://192.168.1.1 Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
Diffstat (limited to 'target/linux/mediatek/image/mt7622.mk')
-rw-r--r--target/linux/mediatek/image/mt7622.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/mediatek/image/mt7622.mk b/target/linux/mediatek/image/mt7622.mk
index 6077e623ff..795bb3fc76 100644
--- a/target/linux/mediatek/image/mt7622.mk
+++ b/target/linux/mediatek/image/mt7622.mk
@@ -202,6 +202,16 @@ define Device/mediatek_mt7622-rfb1-ubi
endef
TARGET_DEVICES += mediatek_mt7622-rfb1-ubi
+define Device/totolink_a8000ru
+ DEVICE_VENDOR := TOTOLINK
+ DEVICE_MODEL := A8000RU
+ DEVICE_DTS := mt7622-totolink-a8000ru
+ DEVICE_DTS_DIR := ../dts
+ DEVICE_PACKAGES := swconfig
+ IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
+endef
+TARGET_DEVICES += totolink_a8000ru
+
define Device/ubnt_unifi-6-lr
DEVICE_VENDOR := Ubiquiti
DEVICE_MODEL := UniFi 6 LR