summaryrefslogtreecommitdiffstats
path: root/target/linux/mediatek/image/mt7622.mk
diff options
context:
space:
mode:
authorINAGAKI Hiroshi <musashino.open@gmail.com>2023-08-27 23:23:20 +0900
committerHauke Mehrtens <hauke@hauke-m.de>2023-09-24 18:42:12 +0200
commit7383eb266b64f374c7109ad1db5360bf91dc11c3 (patch)
treeed00ead8d89e5ad59e89e620679ec70978814fb9 /target/linux/mediatek/image/mt7622.mk
parent9f640cae75ec987f29bf697cee559a0a4ff497e0 (diff)
downloadopenwrt-7383eb266b64f374c7109ad1db5360bf91dc11c3.tar.gz
openwrt-7383eb266b64f374c7109ad1db5360bf91dc11c3.tar.bz2
openwrt-7383eb266b64f374c7109ad1db5360bf91dc11c3.zip
mediatek: add support for Buffalo WSR-3200AX4S
Buffalo WSR-3200AX4S is a 2.4/5 GHz band 11ax (Wi-Fi 6) router, based on MT7622B. Specification: - SoC : MediaTek MT7622B - RAM : DDR3 512 MiB - Flash : SPI-NAND 128 MiB (Winbond W25N01GVZEIG) - WLAN : 2.4/5 GHz 4T4R - 2.4 GHz : MediaTek MT7622B (SoC) - 5 GHz : MediaTek MT7915 - Ethernet : 5x 10/100/1000 Mbps - Switch : MediaTek MT7531 - LEDs/Keys : 6x/5x (2x: buttons, 3x: slide-switches) - UART : through-hole on PCB (J4) - assignment: 3.3V, GND, TX, RX from tri-angle marking - settings : 115200n8 - Power : 12 VDC, 1.5 A Flash instruction using factory.bin image: 1. Boot WSR-3200AX4S with "Router" mode 2. Access to "http://192.168.11.1/" and open firmware update page ("ファームウェア更新") 3. Select the OpenWrt factory.bin image and click update ("更新実行") button 4. Wait ~120 seconds to complete flashing Note: - This device has 2x OS images on flash. The first one will always be used for booting and the secondary is for backup. - This support generates multiple factory*.bin image: - factory.bin : for flashing from OEM WebUI - factory-uboot.bin: for flashing from U-Boot or clean installation via sysupgrade (don't use for normal sysupgrade) Known issues: - Wi-Fi MAC addresses won't be applied to each adapter. MAC Addresses: LAN : C4:3C:EA:xx:xx:60 (board_data, mac (text)) WAN : C4:3C:EA:xx:xx:60 (board_data, mac (text)) 2.4 GHz: C4:3C:EA:xx:xx:61 5 GHz : C4:3C:EA:xx:xx:68 Signed-off-by: INAGAKI Hiroshi <musashino.open@gmail.com>
Diffstat (limited to 'target/linux/mediatek/image/mt7622.mk')
-rw-r--r--target/linux/mediatek/image/mt7622.mk41
1 files changed, 29 insertions, 12 deletions
diff --git a/target/linux/mediatek/image/mt7622.mk b/target/linux/mediatek/image/mt7622.mk
index 6f64740628..65db1ebe2e 100644
--- a/target/linux/mediatek/image/mt7622.mk
+++ b/target/linux/mediatek/image/mt7622.mk
@@ -1,5 +1,7 @@
DTS_DIR := $(DTS_DIR)/mediatek
+DEVICE_VARS += BUFFALO_TRX_MAGIC
+
define Image/Prepare
# For UBI we want only one extra block
rm -f $(KDIR)/ubi_mark
@@ -95,33 +97,38 @@ define Device/bananapi_bpi-r64
endef
TARGET_DEVICES += bananapi_bpi-r64
-define Device/buffalo_wsr-2533dhp2
+define Device/buffalo_wsr
DEVICE_VENDOR := Buffalo
- DEVICE_MODEL := WSR-2533DHP2
- DEVICE_DTS := mt7622-buffalo-wsr-2533dhp2
DEVICE_DTS_DIR := ../dts
- IMAGE_SIZE := 59392k
KERNEL_SIZE := 6144k
BLOCKSIZE := 128k
PAGESIZE := 2048
- SUBPAGESIZE := 512
UBINIZE_OPTS := -E 5
BUFFALO_TAG_PLATFORM := MTK
BUFFALO_TAG_VERSION := 9.99
BUFFALO_TAG_MINOR := 9.99
IMAGES += factory.bin factory-uboot.bin
- KERNEL_INITRAMFS := kernel-bin | lzma | \
+ KERNEL_INITRAMFS = kernel-bin | lzma | \
fit lzma $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb with-initrd | \
buffalo-trx
- IMAGE/factory.bin := append-ubi | \
- buffalo-trx 0x32504844 $$$$@ $(KDIR)/ubi_mark | \
- buffalo-enc WSR-2533DHP2 $$(BUFFALO_TAG_VERSION) -l | \
- buffalo-tag-dhp WSR-2533DHP2 JP JP | buffalo-enc-tag -l | buffalo-dhp-image
+ IMAGE/factory.bin = append-ubi | \
+ buffalo-trx $$$$(BUFFALO_TRX_MAGIC) $$$$@ $(KDIR)/ubi_mark | \
+ buffalo-enc $$(DEVICE_MODEL) $$(BUFFALO_TAG_VERSION) -l | \
+ buffalo-tag-dhp $$(DEVICE_MODEL) JP JP | buffalo-enc-tag -l | buffalo-dhp-image
IMAGE/factory-uboot.bin := append-ubi | \
- buffalo-trx 0x32504844 $$$$@ $(KDIR)/ubi_mark
+ buffalo-trx $$$$(BUFFALO_TRX_MAGIC) $$$$@ $(KDIR)/ubi_mark
IMAGE/sysupgrade.bin := \
- buffalo-trx 0x32504844 $(KDIR)/tmp/$$(DEVICE_NAME).null | \
+ buffalo-trx $$$$(BUFFALO_TRX_MAGIC) $(KDIR)/tmp/$$(DEVICE_NAME).null | \
sysupgrade-tar kernel=$$$$@ | append-metadata
+endef
+
+define Device/buffalo_wsr-2533dhp2
+ $(Device/buffalo_wsr)
+ DEVICE_MODEL := WSR-2533DHP2
+ DEVICE_DTS := mt7622-buffalo-wsr-2533dhp2
+ IMAGE_SIZE := 59392k
+ SUBPAGESIZE := 512
+ BUFFALO_TRX_MAGIC := 0x32504844
DEVICE_PACKAGES := kmod-mt7615-firmware swconfig
DEVICE_COMPAT_VERSION := 1.1
DEVICE_COMPAT_MESSAGE := Partition table has been changed due to kernel size restrictions. \
@@ -130,6 +137,16 @@ define Device/buffalo_wsr-2533dhp2
endef
TARGET_DEVICES += buffalo_wsr-2533dhp2
+define Device/buffalo_wsr-3200ax4s
+ $(Device/buffalo_wsr)
+ DEVICE_MODEL := WSR-3200AX4S
+ DEVICE_DTS := mt7622-buffalo-wsr-3200ax4s
+ IMAGE_SIZE := 24576k
+ BUFFALO_TRX_MAGIC := 0x33504844
+ DEVICE_PACKAGES := kmod-mt7915-firmware
+endef
+TARGET_DEVICES += buffalo_wsr-3200ax4s
+
define Device/elecom_wrc-2533gent
DEVICE_VENDOR := Elecom
DEVICE_MODEL := WRC-2533GENT