summaryrefslogtreecommitdiffstats
path: root/target/linux/mediatek/image/mt7622.mk
diff options
context:
space:
mode:
authorAlex Hansen <mralexh123@gmail.com>2022-10-13 14:36:40 -0400
committerDaniel Golle <daniel@makrotopia.org>2022-12-06 12:43:15 +0000
commit7dbac3433fef1af0f76a515e962db450c3407c19 (patch)
treef88fac6ee6a750356de58e6698d2f823aac698d9 /target/linux/mediatek/image/mt7622.mk
parent84183f0d98c5da8d3b8e509a9d750f71e4b934e2 (diff)
downloadopenwrt-7dbac3433fef1af0f76a515e962db450c3407c19.tar.gz
openwrt-7dbac3433fef1af0f76a515e962db450c3407c19.tar.bz2
openwrt-7dbac3433fef1af0f76a515e962db450c3407c19.zip
mediatek: add support for reyee AX3200-E5
This is yet another model of the Ruijie RG-EW3200GX PRO with a slightly different flash layout, install process is the same. Specifications: SoC: MT7622B RAM: 256MB Flash: XMC XM25QH128C or Winbond WQ25Q128JVSQ 16MB SPI NOR Ethernet: 5x1GbE Switch: MT7531BE WiFi: 2.4G: MT7622 5G: MT7915AN+MT7975AN 3LEDs: System LED(blue) + Mesh LED(green) + Mesh LED(red) 2Keys: Mesh button + Reset button UART: Marked J19 on board. 3.3v, 115200n1 Power: 12V 2.5A Flash instruction: 1. Serve the initramfs.img using a TFTP server with address 10.10.10.3. 2. Interrupt the uboot startup process via UART. 3. Select "System Load Linux to SDRAM via TFTP" item. 4. (important) Back up firmware(mtd7) partitions with: dd if=/dev/mtd7 of=/tmp/firmware.bin and then download the firmware.bin image via SCP. 5. Flash the OpenWrt sysupgrade firmware. Recovery stock firmware: 1. Transfer the firmware.bin image to the device. 2. Flash the image with: mtd write firmware.bin firmware Signed-off-by: Alex Hansen <mralexh123@gmail.com> Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'target/linux/mediatek/image/mt7622.mk')
-rw-r--r--target/linux/mediatek/image/mt7622.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/mediatek/image/mt7622.mk b/target/linux/mediatek/image/mt7622.mk
index f9cd18fd41..9760097ee4 100644
--- a/target/linux/mediatek/image/mt7622.mk
+++ b/target/linux/mediatek/image/mt7622.mk
@@ -237,6 +237,15 @@ define Device/ruijie_rg-ew3200gx-pro
endef
TARGET_DEVICES += ruijie_rg-ew3200gx-pro
+define Device/reyee_ax3200-e5
+ DEVICE_VENDOR := reyee
+ DEVICE_MODEL := AX3200 E5
+ DEVICE_DTS := mt7622-reyee-ax3200-e5
+ DEVICE_DTS_DIR := ../dts
+ DEVICE_PACKAGES := kmod-mt7915e
+endef
+TARGET_DEVICES += reyee_ax3200-e5
+
define Device/totolink_a8000ru
DEVICE_VENDOR := TOTOLINK
DEVICE_MODEL := A8000RU