summaryrefslogtreecommitdiffstats
path: root/target/linux/mediatek/image/mt7622.mk
diff options
context:
space:
mode:
authorLanghua Ye <y1248289414@outlook.com>2022-03-04 21:41:46 +0800
committerHauke Mehrtens <hauke@hauke-m.de>2022-03-05 21:06:35 +0100
commitce8a33b021a703b1933f627835f6cdc88c0ecdd3 (patch)
tree6b62d616706a0df5b04802b068f81b11b5ac76d5 /target/linux/mediatek/image/mt7622.mk
parentdf1383f7964527b2e7178ae744cd167a2c230f9f (diff)
downloadopenwrt-ce8a33b021a703b1933f627835f6cdc88c0ecdd3.tar.gz
openwrt-ce8a33b021a703b1933f627835f6cdc88c0ecdd3.tar.bz2
openwrt-ce8a33b021a703b1933f627835f6cdc88c0ecdd3.zip
mediatek: add support for Ruijie RG-EW3200GX PRO
X32 Pro is another product name for it in the Chinese market. Specifications: - SoC: MT7622B - RAM: 256MB - Flash: XMC XM25QH128C or Winbond WQ25Q128JVSQ 16MB SPI NOR - Ethernet: 5x1GbE - Switch: MT7531BE - WiFi: 2.4G: MT7622 5G: MT7915AN+MT7975AN - 3LEDs: System LED(blue) + Mesh LED(green) + Mesh LED(red) - 2Keys: Mesh button + Reset button - UART: Marked J19 on board. 3.3v, 115200n1 - Power: 12V 2.5A MAC addresses as verified by OEM firmware: use address source WAN *:F4 ethaddr@product_info LAN *:F5 5g *:F6 2g *:F7 Flash instruction: 1. Serve the initramfs.img using a TFTP server with address 10.10.10.3. 2. Interrupt the uboot startup process via UART. 3. Select "System Load Linux to SDRAM via TFTP" item. 4. (important) Back up firmware(mtd7) partitions with: dd if=/dev/mtd7 of=/tmp/firmware.bin and then download the firmware.bin image via SCP. 5. Flash the OpenWrt sysupgrade firmware. Recovery stock firmware: 1. Transfer the firmware.bin image to the device. 2. Flash the image with: mtd write firmware.bin firmware Signed-off-by: Langhua Ye <y1248289414@outlook.com>
Diffstat (limited to 'target/linux/mediatek/image/mt7622.mk')
-rw-r--r--target/linux/mediatek/image/mt7622.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/mediatek/image/mt7622.mk b/target/linux/mediatek/image/mt7622.mk
index 3517748510..daec843b49 100644
--- a/target/linux/mediatek/image/mt7622.mk
+++ b/target/linux/mediatek/image/mt7622.mk
@@ -203,6 +203,15 @@ define Device/mediatek_mt7622-rfb1-ubi
endef
TARGET_DEVICES += mediatek_mt7622-rfb1-ubi
+define Device/ruijie_rg-ew3200gx-pro
+ DEVICE_VENDOR := Ruijie
+ DEVICE_MODEL := RG-EW3200GX PRO
+ DEVICE_DTS := mt7622-ruijie-rg-ew3200gx-pro
+ DEVICE_DTS_DIR := ../dts
+ DEVICE_PACKAGES := kmod-mt7915e
+endef
+TARGET_DEVICES += ruijie_rg-ew3200gx-pro
+
define Device/totolink_a8000ru
DEVICE_VENDOR := TOTOLINK
DEVICE_MODEL := A8000RU