summaryrefslogtreecommitdiffstats
path: root/target/linux/mediatek/image/mt7622.mk
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2021-03-01 14:07:33 +0000
committerDaniel Golle <daniel@makrotopia.org>2021-03-01 19:33:46 +0000
commitded54ae19622423b5e3e30c7ee59316af01f8bf3 (patch)
treef5b00593c76a67d638689b5dae5b3107c80f79d1 /target/linux/mediatek/image/mt7622.mk
parent7a7b2fd809809fbd7045bd3dad4fc896a6fef06f (diff)
downloadopenwrt-ded54ae19622423b5e3e30c7ee59316af01f8bf3.tar.gz
openwrt-ded54ae19622423b5e3e30c7ee59316af01f8bf3.tar.bz2
openwrt-ded54ae19622423b5e3e30c7ee59316af01f8bf3.zip
mediatek: mt7622: bpi-r64: simplify eMMC install procedure
Write everything needed for eMMC install into the gaps between partitions on SD card. In that way, installation to eMMC only needs the SD card, no additional files need to be loaded via TFTP any more. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'target/linux/mediatek/image/mt7622.mk')
-rw-r--r--target/linux/mediatek/image/mt7622.mk9
1 files changed, 4 insertions, 5 deletions
diff --git a/target/linux/mediatek/image/mt7622.mk b/target/linux/mediatek/image/mt7622.mk
index ec1e15d5e5..afda48043f 100644
--- a/target/linux/mediatek/image/mt7622.mk
+++ b/target/linux/mediatek/image/mt7622.mk
@@ -45,14 +45,13 @@ define Device/bananapi_bpi-r64
uboot-mt7622_bananapi_bpi-r64-sdmmc \
e2fsprogs mkf2fs f2fsck \
kmod-nls-cp437 kmod-nls-iso8859-1 kmod-vfat blockd
- ARTIFACTS := boot-sdcard.img boot-emmc.img bl2-emmc.bin bl31-emmc.bin header-emmc.bin
+ ARTIFACTS := header-emmc.bin sdcard.img
IMAGES := sysupgrade.itb
KERNEL_INITRAMFS_SUFFIX := -recovery.itb
- ARTIFACT/boot-sdcard.img := mt7622-gpt sdmmc | mmc-header sdmmc | pad-to 512k | bl2 sdmmc-2ddr | pad-to 2M | bl31-uboot bananapi_bpi-r64-sdmmc | pad-to 6M
- ARTIFACT/boot-emmc.img := mt7622-gpt emmc | mmc-header emmc | pad-to 2M | bl31-uboot bananapi_bpi-r64-emmc | pad-to 6M
ARTIFACT/header-emmc.bin := mt7622-gpt emmc | mmc-header emmc
- ARTIFACT/bl31-emmc.bin := bl31-uboot bananapi_bpi-r64-emmc
- ARTIFACT/bl2-emmc.bin := bl2 emmc-2ddr
+ ARTIFACT/sdcard.img := mt7622-gpt sdmmc | mmc-header sdmmc | pad-to 128k | append-image header-emmc.bin | pad-to 256k |\
+ bl2 emmc-2ddr | pad-to 512k | bl2 sdmmc-2ddr | pad-to 1M | bl31-uboot bananapi_bpi-r64-emmc | pad-to 2M |\
+ bl31-uboot bananapi_bpi-r64-sdmmc | pad-to 6M
KERNEL := kernel-bin | gzip
KERNEL_INITRAMFS := kernel-bin | lzma | fit lzma $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb with-initrd | pad-to 128k
IMAGE/sysupgrade.itb := append-kernel | fit gzip $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb external-static-with-rootfs | append-metadata