summaryrefslogtreecommitdiffstats
path: root/target/linux/mpc85xx/Makefile
diff options
context:
space:
mode:
authorChris Blake <chrisrblake93@gmail.com>2017-10-20 12:36:25 -0500
committerMathias Kresin <dev@kresin.me>2017-10-25 09:21:54 +0200
commitec269290db46d491ae61adb64b19b3f171b8e2a3 (patch)
tree91602b2a24759dd57794878f1afb0f7769dbda92 /target/linux/mpc85xx/Makefile
parentdcf62cb24efb2fd69eca921085c3f4306e76e8a2 (diff)
downloadopenwrt-ec269290db46d491ae61adb64b19b3f171b8e2a3.tar.gz
openwrt-ec269290db46d491ae61adb64b19b3f171b8e2a3.tar.bz2
openwrt-ec269290db46d491ae61adb64b19b3f171b8e2a3.zip
mpc85xx: use new build code style
The following moves the mpc85xx target (generic & P1020) to the new build code style. Compile & Flash tested on an Aerohive HiveAP-330. Signed-off-by: Chris Blake <chrisrblake93@gmail.com> Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/mpc85xx/Makefile')
-rw-r--r--target/linux/mpc85xx/Makefile9
1 files changed, 1 insertions, 8 deletions
diff --git a/target/linux/mpc85xx/Makefile b/target/linux/mpc85xx/Makefile
index 8428bec6bc..b181e67c0e 100644
--- a/target/linux/mpc85xx/Makefile
+++ b/target/linux/mpc85xx/Makefile
@@ -16,17 +16,10 @@ SUBTARGETS:=generic p1020
KERNEL_PATCHVER:=4.9
-define Target/Description
- Build images for the Freescale MPC85xx based boards.
-endef
+KERNELNAME:=zImage
include $(INCLUDE_DIR)/target.mk
-KERNEL_IMAGES := zImage
-ifeq ($(SUBTARGET),generic)
-KERNEL_IMAGES += cuImage.tl-wdr4900-v1
-endif
-
DEFAULT_PACKAGES += \
kmod-input-core kmod-input-gpio-keys kmod-button-hotplug \
kmod-leds-gpio swconfig kmod-ath9k wpad-mini