summaryrefslogtreecommitdiffstats
path: root/target/linux/mpc85xx/image/Makefile
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2019-01-29 23:52:27 +0100
committerChristian Lamparter <chunkeey@gmail.com>2019-06-10 11:21:35 +0200
commit1e41de2f48e284c9d6658f9403365651178f6826 (patch)
tree90d34b3f3846e72374beb796576ade2951736274 /target/linux/mpc85xx/image/Makefile
parent452d88e8f798c550151cd1e1d204a528fb00db08 (diff)
downloadopenwrt-1e41de2f48e284c9d6658f9403365651178f6826.tar.gz
openwrt-1e41de2f48e284c9d6658f9403365651178f6826.tar.bz2
openwrt-1e41de2f48e284c9d6658f9403365651178f6826.zip
mpc85xx: convert TL-WDR4900 v1 to simpleImage
Converts the TP-Link WDR4900 v1 to use the simpleImage in the hopes of prolonging the life of the device. While at it, the patch makes the fdt.bin an ARTIFACT and sets the KERNEL_SIZE to 2684 KiB as a precaution since the stock u-boot is using a fixed kernel size. Note: Give the image some time, it will take much longer to extract and boot. [tested for 4.14/4.19] Signed-off-by: Christian Lamparter <chunkeey@gmail.com> Co-authored-by: Pawel Dembicki <paweldembicki@gmail.com> Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
Diffstat (limited to 'target/linux/mpc85xx/image/Makefile')
-rw-r--r--target/linux/mpc85xx/image/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/target/linux/mpc85xx/image/Makefile b/target/linux/mpc85xx/image/Makefile
index f95e38d5c6..4bd4efc747 100644
--- a/target/linux/mpc85xx/image/Makefile
+++ b/target/linux/mpc85xx/image/Makefile
@@ -52,11 +52,15 @@ define Device/tl-wdr4900-v1
TPLINK_HWREV := 1
TPLINK_FLASHLAYOUT := 16Mppc
KERNEL_SIZE := 2684k
- KERNEL_NAME := cuImage.tl-wdr4900-v1
+ KERNEL_NAME := simpleImage.tl-wdr4900-v1
KERNEL_INITRAMFS :=
+ KERNEL := kernel-bin | uImage none
+ KERNEL_ENTRY := 0x1000000
+ KERNEL_LOADADDR := 0x1000000
SUPPORTED_DEVICES:=tl-wdr4900-v1 tplink,tl-wdr4900-v1
+ ARTIFACTS := fdt.bin
+ ARTIFACT/fdt.bin := append-dtb
IMAGES := fdt.bin factory.bin sysupgrade.bin
- IMAGE/fdt.bin := append-dtb
IMAGE/sysupgrade.bin := append-rootfs | mktplinkfw sysupgrade | append-metadata
IMAGE/factory.bin := append-rootfs | mktplinkfw factory
endef