summaryrefslogtreecommitdiffstats
path: root/target/linux/mpc85xx/image/Makefile
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-02-20 08:27:26 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-02-20 08:27:26 +0000
commit33ba984628c5ce88e16010b009c6566ff954a2d5 (patch)
treebe1f84881a13719c6ecc6a25870fd417dd1f2dde /target/linux/mpc85xx/image/Makefile
parent2d9e89b24ce57e107fc67b7121e57770608d15ef (diff)
downloadopenwrt-33ba984628c5ce88e16010b009c6566ff954a2d5.tar.gz
openwrt-33ba984628c5ce88e16010b009c6566ff954a2d5.tar.bz2
openwrt-33ba984628c5ce88e16010b009c6566ff954a2d5.zip
mpc85xx: use a foreach loop to copy boot images
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 35689
Diffstat (limited to 'target/linux/mpc85xx/image/Makefile')
-rw-r--r--target/linux/mpc85xx/image/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/target/linux/mpc85xx/image/Makefile b/target/linux/mpc85xx/image/Makefile
index b762515ec3..0826cfb27b 100644
--- a/target/linux/mpc85xx/image/Makefile
+++ b/target/linux/mpc85xx/image/Makefile
@@ -8,9 +8,12 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
DTS_TARGETS = mpc8548cds_32b p1010rdb
+BOOT_IMAGES:=zImage
define Image/Prepare
- cp $(LINUX_DIR)/arch/powerpc/boot/zImage $(KDIR)/zImage
+ $(foreach image,$(BOOT_IMAGES),
+ cp $(LINUX_DIR)/arch/powerpc/boot/$(image) $(KDIR)/$(image)
+ )
endef
define Image/BuildKernel