summaryrefslogtreecommitdiffstats
path: root/target/linux/mpc85xx/image/Makefile
diff options
context:
space:
mode:
authorPawel Dembicki <paweldembicki@gmail.com>2018-12-30 07:38:45 +0000
committerChristian Lamparter <chunkeey@gmail.com>2019-01-13 11:31:43 +0100
commit5de6aed42c3519f819b913a8b218adb5ea827872 (patch)
tree5c7a3260d8e27e8c1038a577438d7b3005255ac0 /target/linux/mpc85xx/image/Makefile
parented2839ac41908905294f82de36b68757e78545e6 (diff)
downloadopenwrt-5de6aed42c3519f819b913a8b218adb5ea827872.tar.gz
openwrt-5de6aed42c3519f819b913a8b218adb5ea827872.tar.bz2
openwrt-5de6aed42c3519f819b913a8b218adb5ea827872.zip
mpc85xx: add support for Freescale (NXP) P2020RDB
This commit add initial support for Freescale (NXP) P2020RDB Hardware: SoC: P2020 2x1GHz DRAM: 512-1GB DDR3 2 + 4 GBE (2 separate ports and four in VSC7385) Flash: 16MB NOR, 32MB NAND, 16MB SPI-NOR PCIE x1 and mPCIE x1 SD Reader Interfaces: GBE RJ45 x6 USB2.0 x1 UART x2 I2C x2 JTAG x1 SD x1 PCIE x2 (PCIE and mPCIE) Flash instructions: Place sysupgrade image to 0x80000 address in NOR. Eg. (no brakelines in setenv command): setenv 'firmware_flash tftpboot $loadaddr $firmwarefile; protect off $norfdtaddr +$filesize; erase $norfdtaddr +$filesize; cp.b $loadaddr $norfdtaddr $filesize; protect on $norfdtaddr +$filesize; cmp.b $loadaddr $norfdtaddr $filesize' setenv firmwarefile firmware.bin run firmware_flash Boot (no brakeline in setenv command): setenv bootcmd 'setenv bootargs root=/dev/mtdblock3 rw console=$consoledev, $baudrate rootfstype=squashfs $othbootargs; bootm $norfdtaddr' saveenv boot Known issues: -Switch is unmanaged (VSC 7385 is connected via eLBC, driver uses SPI) -No SD reader support Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com> Signed-off-by: Christian Lamparter <chunkeey@gmail.com> [refreshed patches]
Diffstat (limited to 'target/linux/mpc85xx/image/Makefile')
-rw-r--r--target/linux/mpc85xx/image/Makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/target/linux/mpc85xx/image/Makefile b/target/linux/mpc85xx/image/Makefile
index 00eed88874..dd15d4c610 100644
--- a/target/linux/mpc85xx/image/Makefile
+++ b/target/linux/mpc85xx/image/Makefile
@@ -79,4 +79,23 @@ TARGET_DEVICES += hiveap-330
endif
+ifeq ($(SUBTARGET),p2020)
+
+define Device/p2020rdb
+ DEVICE_TITLE := Freescale P2020RDB
+ DEVICE_DTS_DIR := $(DTS_DIR)/fsl
+ DEVICE_PACKAGES := kmod-hwmon-core kmod-hwmon-lm90 kmod-rtc-ds1307 \
+ kmod-gpio-pca953x kmod-eeprom-at24
+ BLOCKSIZE := 128k
+ KERNEL := kernel-bin | gzip | \
+ fit gzip $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb
+ SUPPORTED_DEVICES := fsl,P2020RDB
+ IMAGES := sysupgrade.bin
+ IMAGE/sysupgrade.bin := append-kernel | append-rootfs | \
+ pad-rootfs $$(BLOCKSIZE) | append-metadata
+endef
+TARGET_DEVICES += p2020rdb
+
+endif
+
$(eval $(call BuildImage))