summaryrefslogtreecommitdiffstats
path: root/target/linux/mpc85xx/image/Makefile
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2018-04-20 06:30:46 +0200
committerMathias Kresin <dev@kresin.me>2018-04-20 20:58:52 +0200
commit74a0d8cd92c7e753c6a342a7b90151ec042a03c5 (patch)
treef0fb63e26b872c1e799d8cf729182df3a2d8861d /target/linux/mpc85xx/image/Makefile
parent5950ab067bcc6ffa9ab6bb0c28c8d9ca45d34eb7 (diff)
downloadopenwrt-74a0d8cd92c7e753c6a342a7b90151ec042a03c5.tar.gz
openwrt-74a0d8cd92c7e753c6a342a7b90151ec042a03c5.tar.bz2
openwrt-74a0d8cd92c7e753c6a342a7b90151ec042a03c5.zip
build: consolidate fake uImage header build commands
Merge the two existing functions and use a parameter for the type header field. It updates the syntax of the former mpc85xx fake ramdisk header command to be compatible with mkimage from u-boot 2018.03 and fixes the build error spotted by the build bot. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/mpc85xx/image/Makefile')
-rw-r--r--target/linux/mpc85xx/image/Makefile12
1 files changed, 1 insertions, 11 deletions
diff --git a/target/linux/mpc85xx/image/Makefile b/target/linux/mpc85xx/image/Makefile
index 7ae6e27b35..4dd1f17321 100644
--- a/target/linux/mpc85xx/image/Makefile
+++ b/target/linux/mpc85xx/image/Makefile
@@ -16,16 +16,6 @@ define Device/Default
KERNEL := kernel-bin
endef
-define Build/append-uImage-fakeramdisk-hdr
- rm -f $@.fakeramdisk
- $(STAGING_DIR_HOST)/bin/mkimage \
- -A $(LINUX_KARCH) -O linux -T ramdisk -C none \
- -n 'fakeramdisk' \
- -s \
- $@.fakeramdisk
- cat $@.fakeramdisk >> $@
-endef
-
define Build/tplink-v1-image
$(STAGING_DIR_HOST)/bin/mktplinkfw \
-H $(TPLINK_HWID) -W $(TPLINK_HWREV) -F $(TPLINK_FLASHLAYOUT) \
@@ -68,7 +58,7 @@ define Device/hiveap-330
IMAGES := fdt.bin sysupgrade.bin
IMAGE/fdt.bin := append-dtb
IMAGE/sysupgrade.bin := append-dtb | pad-to 256k | check-size 256k | \
- append-uImage-fakeramdisk-hdr | pad-to 256k | check-size 512k | \
+ append-uImage-fakehdr ramdisk | pad-to 256k | check-size 512k | \
append-rootfs | pad-rootfs $$(BLOCKSIZE) | pad-to 41216k | check-size 41216k | \
append-kernel | append-metadata
endef