summaryrefslogtreecommitdiffstats
path: root/target/linux/mpc85xx/image/Makefile
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2019-01-08 01:20:56 +0100
committerChristian Lamparter <chunkeey@gmail.com>2019-01-13 11:31:43 +0100
commit97e4311fca73d064d17065e7844699aa777cb157 (patch)
treec61c97c86c75c88e2ab9c81b4015bbe5429c4dc7 /target/linux/mpc85xx/image/Makefile
parent85be0f4c2165051a16c1d1980335d4273473933c (diff)
downloadopenwrt-97e4311fca73d064d17065e7844699aa777cb157.tar.gz
openwrt-97e4311fca73d064d17065e7844699aa777cb157.tar.bz2
openwrt-97e4311fca73d064d17065e7844699aa777cb157.zip
mpc85xx: add support for Sophos RED 15w Rev.1
Hardware ======== CPU: Freescale P1010 PowerPC RAM: 128M DDR3 NAND: 128MiB ETH: RTL8211F SGMII PHY RTL8367B 5-port RGMII switch (not connected to SoC - unmanaged) WiFi: SparkLan WPEA-121N - Atheros AR9382 2T2R abgn USB: 1x USB 2.0 LED: System, Router, Internet, Tunnel controllable LAN1-4, WAN, Power non-controllable BTN: None Installation ============ 1. Power on the device while attached to the Console port. 2. Halt the U-Boot by pressing Enter when prompted. 3. Set the correct bootcmd for booting OpenWRT: > setenv bootargs_owrt "setenv bootargs console=ttyS0,115200" > setenv bootcmd "run bootargs_owrt; nand read 0x1000000 0x300000 0x800000; bootm 0x1000000;" > saveenv 5. Rename OpenWRT initramfs image to 'kernel.bin' and place it in a TFTP server root-directory served on 192.168.1.2/24. Connect your computer to one of the LAN-ports. 4. Boot OpenWRT initramfs image with > run bootargs_owrt; tftpboot 0x1000000 192.168.1.2:kernel.bin; bootm 0x1000000; 6. (Optional) Make a Backup of 'sophos-os1', 'sophos-os2' and 'sophos-data' in case you ever want to go back to the vendor firmware. 7. Create Ubi Volume on mtd4 by executing > ubiformat /dev/mtd4 -y 8. Transfer OpenWRT sysupgrade image to the device via SCP and install it with > sysupgrade -n <openwrt-image-file> Back to Stock ============= If you want to go back to the stock firmware, here is the bootcmd of the vendor firmware: > setenv bootargs console=ttyS0,115200 root=/dev/mtdblock5; nand read 0xc00000 0x00300000 0x100000; nand read 0x1000000 0x00400000 0x00800000; bootm 0x1000000 - 0xc00000 Set it via 'setenv' from the U-Boot shell and don't forget to save it using 'saveenv'! After this, boot the OpenWRT initramfs image just like you would for installation. Write back the three vendor partitions using mtd. Reboot the device afterwards. Signed-off-by: David Bauer <mail@david-bauer.net> [refresh and reorder patches] Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'target/linux/mpc85xx/image/Makefile')
-rw-r--r--target/linux/mpc85xx/image/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/mpc85xx/image/Makefile b/target/linux/mpc85xx/image/Makefile
index 7cbf733852..e803cabcbe 100644
--- a/target/linux/mpc85xx/image/Makefile
+++ b/target/linux/mpc85xx/image/Makefile
@@ -58,6 +58,18 @@ define Device/tl-wdr4900-v1
endef
TARGET_DEVICES += tl-wdr4900-v1
+define Device/red-15w-rev1
+ DEVICE_TITLE := Sophos RED 15w Rev.1
+ DEVICE_PACKAGES := kmod-usb2
+ # Original firmware uses a dedicated DTB-partition.
+ # The bootloader however supports FIT-images.
+ KERNEL = kernel-bin | gzip | fit gzip $(KDIR)/image-$$(DEVICE_DTS).dtb
+ SUPPORTED_DEVICES := sophos,red-15w-rev1
+ IMAGES := sysupgrade.bin
+ IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
+endef
+TARGET_DEVICES += red-15w-rev1
+
endif
ifeq ($(SUBTARGET),p1020)