summaryrefslogtreecommitdiffstats
path: root/target/linux/mpc85xx/image/Makefile
diff options
context:
space:
mode:
authorPawel Dembicki <paweldembicki@gmail.com>2019-01-29 18:26:28 +0000
committerChristian Lamparter <chunkeey@gmail.com>2019-04-13 18:46:40 +0200
commitb3f7a73860ae62da5a39babb1a5f28cb35f0aba0 (patch)
tree808ac90feaf7b8a4f335a392efa343467ae47752 /target/linux/mpc85xx/image/Makefile
parentbb831ca43a0911a78e488b3a354f3c0478068f70 (diff)
downloadopenwrt-b3f7a73860ae62da5a39babb1a5f28cb35f0aba0.tar.gz
openwrt-b3f7a73860ae62da5a39babb1a5f28cb35f0aba0.tar.bz2
openwrt-b3f7a73860ae62da5a39babb1a5f28cb35f0aba0.zip
mpc85xx: generic: Check kernel size for the TL-WDR4900
TP-Link TL-WDR 4900 have u-boot with read-only env. Boot command read only 0x29F000 data from flash. Bigger images causes crc error. It can't be changed. This patch add kernel size checking. Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com> Signed-off-by: Christian Lamparter <chunkeey@gmail.com> [utilize KERNEL_SIZE]
Diffstat (limited to 'target/linux/mpc85xx/image/Makefile')
-rw-r--r--target/linux/mpc85xx/image/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/linux/mpc85xx/image/Makefile b/target/linux/mpc85xx/image/Makefile
index d2c3ae1861..68c0da84ee 100644
--- a/target/linux/mpc85xx/image/Makefile
+++ b/target/linux/mpc85xx/image/Makefile
@@ -51,6 +51,7 @@ define Device/tl-wdr4900-v1
TPLINK_HWID := 0x49000001
TPLINK_HWREV := 1
TPLINK_FLASHLAYOUT := 16Mppc
+ KERNEL_SIZE := 2684k
KERNEL_NAME := cuImage.tl-wdr4900-v1
KERNEL_INITRAMFS :=
SUPPORTED_DEVICES:=tl-wdr4900-v1 tplink,tl-wdr4900-v1