summaryrefslogtreecommitdiffstats
path: root/target/linux/mpc85xx/p1010/target.mk
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2023-03-18 02:28:23 +0100
committerDavid Bauer <mail@david-bauer.net>2023-04-08 14:41:01 +0200
commit765f66810a3324cc35fa6471ee8eeee335ba8c2b (patch)
tree215305e9bb0ce4571394c6eac6260aa44fa6c0fa /target/linux/mpc85xx/p1010/target.mk
parentf058dad1b62d0d6c25ffd8365a8fbf0efb7f6f84 (diff)
downloadopenwrt-765f66810a3324cc35fa6471ee8eeee335ba8c2b.tar.gz
openwrt-765f66810a3324cc35fa6471ee8eeee335ba8c2b.tar.bz2
openwrt-765f66810a3324cc35fa6471ee8eeee335ba8c2b.zip
mpc85xx: add support for Enterasys WS-AP3715i
Hardware -------- SoC: NXP P1010 (1x e500 @ 800MHz) RAM: 256M DDR3 (2x Samsung K4B1G1646G-BCH9) FLASH: 32M NOR (Spansion S25FL256S) BTN: 1x Reset WiFi: 1x Atheros AR9590 2.4 bgn 3x3 2x Atheros AR9590 5.0 an 3x3 ETH: 2x Gigabit Ethernet (Atheros AR8033 / AR8035) UART: 115200 8N1 (RJ-45 Cisco) Installation ------------ 1. Grab the OpenWrt initramfs, rename it to ap3715.bin. Place it in the root directory of a TFTP server and serve it at 192.168.1.66/24. 2. Connect to the serial port and boot the AP. Stop autoboot in U-Boot by pressing Enter when prompted. Credentials are identical to the one in the APs interface. By default it is admin / new2day. 3. Alter the bootcmd in U-Boot: $ setenv ramboot_openwrt "setenv ipaddr 192.168.1.1; setenv serverip 192.168.1.66; tftpboot 0x2000000 ap3715.bin; bootm" $ setenv boot_openwrt "sf probe 0; sf read 0x2000000 0x140000 0x1000000; bootm 0x2000000" $ setenv bootcmd "run boot_openwrt" $ saveenv 4. Boot the initramfs image $ run ramboot_openwrt 5. Transfer the OpenWrt sysupgrade image to the AP using SCP. Install using sysupgrade. $ sysupgrade -n <path-to-sysupgrade.bin> Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/mpc85xx/p1010/target.mk')
-rw-r--r--target/linux/mpc85xx/p1010/target.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/mpc85xx/p1010/target.mk b/target/linux/mpc85xx/p1010/target.mk
index 86628e32da..fa1bb7542d 100644
--- a/target/linux/mpc85xx/p1010/target.mk
+++ b/target/linux/mpc85xx/p1010/target.mk
@@ -1,5 +1,5 @@
BOARDNAME:=P1010
-KERNEL_IMAGES:=simpleImage.tl-wdr4900-v1
+KERNEL_IMAGES:=simpleImage.tl-wdr4900-v1 simpleImage.ws-ap3715i
define Target/Description
Build firmware images for P1010 based boards.