summaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image
diff options
context:
space:
mode:
authorDamir Samardzic <damir.samardzic@sartura.hr>2018-03-26 09:37:58 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2018-03-31 16:13:19 +0200
commit2534141322b0541daa627a516280638c12a262fe (patch)
tree97e133471b59000fbf8b44801a1864a6677009da /target/linux/mvebu/image
parentdff904a955ee59b1495b82f765884f787d24d540 (diff)
downloadopenwrt-2534141322b0541daa627a516280638c12a262fe.tar.gz
openwrt-2534141322b0541daa627a516280638c12a262fe.tar.bz2
openwrt-2534141322b0541daa627a516280638c12a262fe.zip
mvebu: add support for MACCHIATObin (cortex-a72)
Add initial support for Marvell MACCHIATObin, cortex-a72 based Marvell ARMADA 8040 Community board. Comes in two forms: Single Shot and Double Shot. Specifications: - Quad core Cortex-A72 (up to 2GHz) - DDR4 DIMM slot with optional ECC and single/dual chip select support - Dual 10GbE (1/2.5/10GbE) via copper or SFP 2.5GbE (1/2.5GbE) via SFP 1GbE via copper - SPI Flash - 3 X SATA 3.0 connectors - MicroSD connector - eMMC - PCI x4 3.0 slot - USB 2.0 Headers (Internal) - USB 3.0 connector - Console port (UART) over microUSB connector - 20-pin Connector for CPU JTAG debugger - 2 X UART Headers - 12V input via DC Jack - ATX type power connector - Form Factor: Mini-ITX (170 mm x 170 mm) More details at http://macchiatobin.net Booting from micro SD card: 1. reset U-Boot environment: env default -a saveenv 2. prepare U-Boot with boot script: setenv bootcmd "load mmc 1:1 0x4d00000 boot.scr; source 0x4d00000" saveenv or manually: setenv fdt_name armada-8040-mcbin.dtb setenv image_name Image setenv bootcmd 'mmc dev 1; ext4load mmc 1:1 $kernel_addr $image_name;ext4load mmc 1:1 $fdt_addr $fdt_name;setenv bootargs $console root=/dev/mmcblk1p2 rw rootwait; booti $kernel_addr - $fdt_addr' saveenv Signed-off-by: Damir Samardzic <damir.samardzic@sartura.hr>
Diffstat (limited to 'target/linux/mvebu/image')
-rw-r--r--target/linux/mvebu/image/Makefile1
-rw-r--r--target/linux/mvebu/image/armada-macchiatobin.bootscript10
-rw-r--r--target/linux/mvebu/image/cortex-a72.mk16
3 files changed, 27 insertions, 0 deletions
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index 4f6d8f529e..be01623e86 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -125,5 +125,6 @@ endef
include cortex-a9.mk
include cortex-a53.mk
+include cortex-a72.mk
$(eval $(call BuildImage))
diff --git a/target/linux/mvebu/image/armada-macchiatobin.bootscript b/target/linux/mvebu/image/armada-macchiatobin.bootscript
new file mode 100644
index 0000000000..ae9fdca92d
--- /dev/null
+++ b/target/linux/mvebu/image/armada-macchiatobin.bootscript
@@ -0,0 +1,10 @@
+setenv bootargs "root=PARTUUID=@ROOT@-02 rw rootwait"
+
+if test -n "${console}"; then
+ setenv bootargs "${bootargs} ${console}"
+fi
+
+load mmc 1:1 ${fdt_addr} armada-8040-mcbin.dtb
+load mmc 1:1 ${kernel_addr} Image
+
+booti ${kernel_addr} - ${fdt_addr}
diff --git a/target/linux/mvebu/image/cortex-a72.mk b/target/linux/mvebu/image/cortex-a72.mk
new file mode 100644
index 0000000000..ac9cb50a85
--- /dev/null
+++ b/target/linux/mvebu/image/cortex-a72.mk
@@ -0,0 +1,16 @@
+ifeq ($(SUBTARGET),cortexa72)
+
+define Device/armada-macchiatobin
+ KERNEL_NAME := Image
+ KERNEL := kernel-bin
+ DEVICE_TITLE := MACCHIATObin (SolidRun Armada 8040 Community Board)
+ DEVICE_PACKAGES := e2fsprogs ethtool mkf2fs kmod-fs-vfat kmod-mmc
+ IMAGES := sdcard.img.gz
+ IMAGE/sdcard.img.gz := boot-scr | boot-img-ext4 | sdcard-img-ext4 | gzip | append-metadata
+ DEVICE_DTS := armada-8040-mcbin
+ DTS_DIR := $(DTS_DIR)/marvell
+ SUPPORTED_DEVICES := marvell,armada8040-mcbin
+endef
+TARGET_DEVICES += armada-macchiatobin
+
+endif