summaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image
diff options
context:
space:
mode:
authorTobias Schramm <tobias@t-sys.eu>2024-02-26 12:47:29 +0100
committerChristian Lamparter <chunkeey@gmail.com>2024-03-02 14:21:20 +0100
commit336a531c15e7fa5f8a42a7b9f2662c249aafce89 (patch)
tree1aeca52573c3d4c96f6c36872e95dac88d39e71b /target/linux/mvebu/image
parent1ed01ef606192ca7900b90bc81c4374bbdd5d786 (diff)
downloadopenwrt-336a531c15e7fa5f8a42a7b9f2662c249aafce89.tar.gz
openwrt-336a531c15e7fa5f8a42a7b9f2662c249aafce89.tar.bz2
openwrt-336a531c15e7fa5f8a42a7b9f2662c249aafce89.zip
mvebu: add support for SolidRun ClearFog Pro
The SolidRun ClearFog Pro is a router based on the SolidRun CN9130 SOM. Specs: - SoC: Quad-Core Cortex-A72 CN9130 SoC - RAM: 4GiB DDR4 - Serial: Micro-USB port on front (FT232R, 115200 8n1) - Storage: 8GiB eMMC, microSD card slot, 8MiB SPI NOR flash - Ethernet: 7x GbE (1 port dedicated on SoC, 6 port switch with single GbE CPU port) - SFP: 1x SFP+ - USB: 1x USB-A 3.1 Gen 1 - PCIe: 2x mini PCIe (one slot with USB and SIM card socket) - SATA: 1x M.2 Key-B In addition to the usual connectivity options this device also features an internal mikroBUS expansion connector. SATA is currently untested due to lack of a suitable M.2 SSD. Installation ============ 1. Write sdcard sysupgrade image to microSD card using dd or similar 2. Insert microSD card into router and apply power 3. Device boots into OpenWRT 4. (optional) dd sysupgrade image to /dev/mmcblk0 to install to eMMC Signed-off-by: Tobias Schramm <tobias@t-sys.eu>
Diffstat (limited to 'target/linux/mvebu/image')
-rw-r--r--target/linux/mvebu/image/clearfog-pro.bootscript16
-rw-r--r--target/linux/mvebu/image/cortexa72.mk10
2 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/mvebu/image/clearfog-pro.bootscript b/target/linux/mvebu/image/clearfog-pro.bootscript
new file mode 100644
index 0000000000..2e152445eb
--- /dev/null
+++ b/target/linux/mvebu/image/clearfog-pro.bootscript
@@ -0,0 +1,16 @@
+# Standard Boot-Script
+# use only well-known variable names provided by U-Boot Distro boot
+# This script assumes the boot partition to be partition 1
+# and that the root partition is always partition 2.
+# The vendor u-boot ships without setexpr compiled in.
+
+# figure out partition uuid to pass to the kernel as root=
+part uuid ${devtype} ${devnum}:2 uuid
+
+# generate bootargs (rootfs)
+setenv bootargs root=PARTUUID=${uuid} rootfstype=auto rootwait
+
+echo "Booting Linux with ${bootargs}"
+load ${devtype} ${devnum}:${distro_bootpart} ${fdt_addr_r} @DTB@.dtb
+load ${devtype} ${devnum}:${distro_bootpart} ${kernel_addr_r} Image
+booti ${kernel_addr_r} - ${fdt_addr_r}
diff --git a/target/linux/mvebu/image/cortexa72.mk b/target/linux/mvebu/image/cortexa72.mk
index 26b02e1924..17904dc6c3 100644
--- a/target/linux/mvebu/image/cortexa72.mk
+++ b/target/linux/mvebu/image/cortexa72.mk
@@ -80,3 +80,13 @@ define Device/iei_puzzle-m902
DEVICE_PACKAGES += kmod-rtc-ds1307
endef
TARGET_DEVICES += iei_puzzle-m902
+
+define Device/solidrun_clearfog-pro
+ $(call Device/Default-arm64)
+ SOC := cn9130
+ DEVICE_VENDOR := SolidRun
+ DEVICE_MODEL := ClearFog Pro
+ DEVICE_PACKAGES += kmod-i2c-mux-pca954x
+ BOOT_SCRIPT := clearfog-pro
+endef
+TARGET_DEVICES += solidrun_clearfog-pro