summaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image
diff options
context:
space:
mode:
authorLogan Blyth <mrbojangles3@gmail.com>2022-06-07 21:46:22 -0400
committerChristian Lamparter <chunkeey@gmail.com>2022-06-19 12:40:30 +0200
commit36e46c3c131cb187e94df9bb4c1ef56e3376c268 (patch)
tree20905b7eb9df997c0d2af30e84c21f6eb4dbefc2 /target/linux/mvebu/image
parentcd1b4ea5aab28eb2a6e827c4a3abcafe9e02cf9d (diff)
downloadopenwrt-36e46c3c131cb187e94df9bb4c1ef56e3376c268.tar.gz
openwrt-36e46c3c131cb187e94df9bb4c1ef56e3376c268.tar.bz2
openwrt-36e46c3c131cb187e94df9bb4c1ef56e3376c268.zip
mvebu: add SolidRun ClearFog GT 8K
ClearFog GT 8K is device sold by SolidRun. It is marketed as a development board, not a consumer product. The device tree file for this board is upstream in kernel.org. Signed-off-by: Logan Blyth <mrbojangles3@gmail.com>
Diffstat (limited to 'target/linux/mvebu/image')
-rw-r--r--target/linux/mvebu/image/cortexa72.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/mvebu/image/cortexa72.mk b/target/linux/mvebu/image/cortexa72.mk
index f95ce533ea..84ce0cda9a 100644
--- a/target/linux/mvebu/image/cortexa72.mk
+++ b/target/linux/mvebu/image/cortexa72.mk
@@ -52,6 +52,17 @@ define Device/marvell_macchiatobin-singleshot
endef
TARGET_DEVICES += marvell_macchiatobin-singleshot
+define Device/marvell_clearfog-gt-8k
+ $(call Device/Default-arm64)
+ DEVICE_VENDOR := SolidRun
+ DEVICE_MODEL := Clearfog
+ DEVICE_VARIANT := GT-8K
+ DEVICE_PACKAGES += kmod-i2c-mux-pca954x kmod-crypto-hw-safexcel
+ DEVICE_DTS := armada-8040-clearfog-gt-8k
+ SUPPORTED_DEVICES := marvell,armada8040-clearfog-gt-8k
+endef
+TARGET_DEVICES += marvell_clearfog-gt-8k
+
define Device/iei_puzzle-m901
$(call Device/Default-arm64)
DEVICE_VENDOR := iEi