summaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image
diff options
context:
space:
mode:
authorRobert Marko <robert.marko@sartura.hr>2022-03-30 14:04:10 +0200
committerChristian 'Ansuel' Marangi <ansuelsmth@gmail.com>2022-06-29 13:08:59 +0200
commit57a38c8d3e85dd94d4912febc3906db77a855b43 (patch)
treef0a61c317e938981d659beacc3c3fd665f575f95 /target/linux/mvebu/image
parent7f73acade0cde61341cb77e0dc74de51ac059d4f (diff)
downloadopenwrt-57a38c8d3e85dd94d4912febc3906db77a855b43.tar.gz
openwrt-57a38c8d3e85dd94d4912febc3906db77a855b43.tar.bz2
openwrt-57a38c8d3e85dd94d4912febc3906db77a855b43.zip
mvebu: add Methode euroDPU support
Add support for Methode euroDPU which is based on uDPU but does not have a second SFP cage, instead of which a Maxlinear G.hn IC is used. PHY mode is set to 1000Base-X despite Maxlinear IC being capable of 2500Base-X since until 5.15 support for mvebu is available trying to use 2500Base-X will cause buffer overruns for which the fix is not easily backportable. Installation instructions: 1. Boot the FIT initramfs image (openwrt-mvebu-cortexa53-methode_edpu-initramfs.itb) 2. sysupgrade using the openwrt-mvebu-cortexa53-methode_edpu-firmware.tgz Signed-off-by: Robert Marko <robert.marko@sartura.hr>
Diffstat (limited to 'target/linux/mvebu/image')
-rw-r--r--target/linux/mvebu/image/cortexa53.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/mvebu/image/cortexa53.mk b/target/linux/mvebu/image/cortexa53.mk
index bfaa597d9a..afe8d9ce21 100644
--- a/target/linux/mvebu/image/cortexa53.mk
+++ b/target/linux/mvebu/image/cortexa53.mk
@@ -92,3 +92,11 @@ define Device/methode_udpu
BOOT_SCRIPT := udpu
endef
TARGET_DEVICES += methode_udpu
+
+define Device/methode_edpu
+ $(call Device/methode_udpu)
+ DEVICE_MODEL := eDPU
+ DEVICE_DTS := armada-3720-eDPU
+ KERNEL_INITRAMFS := kernel-bin | gzip | fit gzip $$(KDIR)/image-$$(DEVICE_DTS).dtb
+endef
+TARGET_DEVICES += methode_edpu