summaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-13 16:02:52 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-13 16:59:28 +0100
commit6f57e32f9502daf707dc1b04bf12a3a99e60b471 (patch)
tree947dfe74e0fa60a84af8a1e596d0c320980319b8 /target/linux/mvebu/image
parent87b668765e1e987aebef8cf0aae657569b631477 (diff)
downloadopenwrt-6f57e32f9502daf707dc1b04bf12a3a99e60b471.tar.gz
openwrt-6f57e32f9502daf707dc1b04bf12a3a99e60b471.tar.bz2
openwrt-6f57e32f9502daf707dc1b04bf12a3a99e60b471.zip
mvebu: remove the clearfog-bundle
It is obsoleted by proper SD card image support Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/mvebu/image')
-rw-r--r--target/linux/mvebu/image/Makefile14
1 files changed, 1 insertions, 13 deletions
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index d8517a9bdb..d4596c5935 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -17,17 +17,6 @@ define Build/dtb
$(call Image/BuildDTB,$(DTS_DIR)/$(DEVICE_DTS).dts,$@.dtb)
endef
-define Build/clearfog-bundle
- rm -f $@.new
- $(TAR) -cp --numeric-owner --owner=0 --group=0 --sort=name \
- $(if $(SOURCE_DATE_EPOCH),--mtime="@$(SOURCE_DATE_EPOCH)") \
- --file=$@.new -C $(TARGET_DIR)/ .
- $(TAR) -rp --numeric-owner --owner=0 --group=0 --sort=name \
- $(if $(SOURCE_DATE_EPOCH),--mtime="@$(SOURCE_DATE_EPOCH)") \
- --file=$@.new -C $(dir $(IMAGE_KERNEL)) $(notdir $(IMAGE_KERNEL)) $(notdir $(IMAGE_KERNEL).dtb)
- gzip -9n -c $@.new > $@
-endef
-
# SD-Card Images:
# these values are optimized for a 4GB labeled sdcard that actually holds 7744512 sectors of 512 byte
# MBR: 2048 sectors
@@ -186,8 +175,7 @@ define Device/armada-388-clearfog
KERNEL := dtb | kernel-bin
DEVICE_TITLE := SolidRun ClearFog
DEVICE_PACKAGES := mkf2fs e2fsprogs swconfig kmod-fs-vfat kmod-nls-cp437 kmod-nls-iso8859-1
- IMAGES := bundle.tar.gz sdcard.img.gz
- IMAGE/bundle.tar.gz := clearfog-bundle
+ IMAGES := sdcard.img.gz
IMAGE/sdcard.img.gz := boot-scr | boot-img | sdcard-img | gzip
IMAGE_NAME = $$(IMAGE_PREFIX)-$$(2)
endef