summaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image
diff options
context:
space:
mode:
authorStijn Segers <foss@volatilesystems.org>2024-03-19 22:55:11 +0100
committerRobert Marko <robimarko@gmail.com>2024-04-03 17:49:53 +0200
commitab2fe43163ed76bfa10b53043982bb6443e362e6 (patch)
tree29665577a25607b4a6aaa13b872f33749c932a9b /target/linux/mvebu/image
parent2260ec4fb7a4689482b6d55b1ffcb50dfe7c6fcb (diff)
downloadopenwrt-ab2fe43163ed76bfa10b53043982bb6443e362e6.tar.gz
openwrt-ab2fe43163ed76bfa10b53043982bb6443e362e6.tar.bz2
openwrt-ab2fe43163ed76bfa10b53043982bb6443e362e6.zip
mvebu: cortexa9: set DTS dir for 6.6
With 6.6, all DTSes were moved to their vendor subdirectories. ARM64 DTSes already used this scheme, but 32 bit Cortex A9 did not, prior to 6.6. Introduce a kernel version check to keep backward compatibility with 6.1. Suggested-by: Robert Marko <robimarko@gmail.com> Signed-off-by: Stijn Segers <foss@volatilesystems.org>
Diffstat (limited to 'target/linux/mvebu/image')
-rw-r--r--target/linux/mvebu/image/cortexa9.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/target/linux/mvebu/image/cortexa9.mk b/target/linux/mvebu/image/cortexa9.mk
index d97509f4d6..270c631474 100644
--- a/target/linux/mvebu/image/cortexa9.mk
+++ b/target/linux/mvebu/image/cortexa9.mk
@@ -3,6 +3,10 @@
# Copyright (C) 2012-2016 OpenWrt.org
# Copyright (C) 2016 LEDE-project.org
+ifneq ($(KERNEL),6.1)
+DTS_DIR := $(DTS_DIR)/marvell
+endif
+
define Build/fortigate-header
( \
dd if=/dev/zero bs=384 count=1 2>/dev/null; \