summaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image
diff options
context:
space:
mode:
authorVladimir Vid <vladimir.vid@sartura.hr>2019-06-19 21:00:03 +0200
committerPetr Štetiar <ynezz@true.cz>2019-06-28 21:49:33 +0200
commitc2e819537f9538f58e94d3fff2b99b4f2493e9d8 (patch)
tree3cdb58d99e3e64d7ed8943f745b976f4a820bae4 /target/linux/mvebu/image
parent95c1dc5e8678a1fd87234a4d77c8c6643703023c (diff)
downloadopenwrt-c2e819537f9538f58e94d3fff2b99b4f2493e9d8.tar.gz
openwrt-c2e819537f9538f58e94d3fff2b99b4f2493e9d8.tar.bz2
openwrt-c2e819537f9538f58e94d3fff2b99b4f2493e9d8.zip
mvebu: add initial support for uDPU board
This adds initial support for micro-DPU (uDPU) board which is based on Armada-3720 SoC. micro-DPU is the single-port FTTdp distribution point unit made by Methode Electronics which offers complete modularity with replaceable SFP modules both for uplink and downlink (G.hn over twisted-pair, G.hn over coax, 1G and 2.5G Ethernet over Cat-5e cable). On-board features: - 512 MiB DDR3 - 2 x 2.5G SFP via HSGMII SERDES interface to the A3720 SoC - USB 2.0 Type-C connector - 4GB eMMC - ETSI TS 101548 reverse powering via twisted pair (RJ45) or coax (F Type) uDPU is intented to run on kernel 4.19 on newer due to the SFP and hardware support. Signed-off-by: Vladimir Vid <vladimir.vid@sartura.hr>
Diffstat (limited to 'target/linux/mvebu/image')
-rw-r--r--target/linux/mvebu/image/cortex-a53.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/mvebu/image/cortex-a53.mk b/target/linux/mvebu/image/cortex-a53.mk
index d7014d6f02..228155ec11 100644
--- a/target/linux/mvebu/image/cortex-a53.mk
+++ b/target/linux/mvebu/image/cortex-a53.mk
@@ -35,4 +35,17 @@ define Device/marvell_armada-3720-db
endef
TARGET_DEVICES += marvell_armada-3720-db
+define Device/methode_uDPU
+ $(call Device/Default-arm64)
+ DEVICE_TITLE := Methode micro-DPU (uDPU)
+ DEVICE_DTS := armada-3720-uDPU
+ KERNEL_LOADADDR := 0x00080000
+ KERNEL_INITRAMFS := kernel-bin | gzip | fit gzip $$(DTS_DIR)/$$(DEVICE_DTS).dtb
+ KERNEL_INITRAMFS_SUFFIX := .itb
+ DEVICE_PACKAGES := f2fs-tools e2fsprogs fdisk ethtool kmod-usb2 kmod-usb3 \
+ kmod-e100 kmod-e1000 kmod-e1000e kmod-igb kmod-ixgbevf \
+ kmod-mdio-gpio kmod-switch-mvsw61xx
+endef
+TARGET_DEVICES += methode_uDPU
+
endif