summaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image
diff options
context:
space:
mode:
authorMarko Ratkaj <marko.ratkaj@sartura.hr>2017-04-06 20:13:31 +0200
committerLuka Perkov <luka.perkov@sartura.hr>2017-05-14 00:34:03 +0200
commitee1cee2cac67108194f1496c29fead90afff1763 (patch)
tree016b1247a7d94c46d2580bd19883fda0de2b1b36 /target/linux/mvebu/image
parentf564fcc6bfb7bae4ca7768f8b30f5348fb472d97 (diff)
downloadopenwrt-ee1cee2cac67108194f1496c29fead90afff1763.tar.gz
openwrt-ee1cee2cac67108194f1496c29fead90afff1763.tar.bz2
openwrt-ee1cee2cac67108194f1496c29fead90afff1763.zip
mvebu: add ClearFog Base support
Add support for SolidRun ClearFog Base board. The base model is a smaller version of ClearFog Pro without the DSA switch, replacing it with a second copper gigabit port, and only one PCIe socket. Signed-off-by: Marko Ratkaj <marko.ratkaj@sartura.hr>
Diffstat (limited to 'target/linux/mvebu/image')
-rw-r--r--target/linux/mvebu/image/Makefile20
-rw-r--r--target/linux/mvebu/image/cfbase-boot.script7
2 files changed, 27 insertions, 0 deletions
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index dcbf4a67b3..f112bb9a1e 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -28,6 +28,11 @@ define Build/boot-scr-cfpro
mkimage -A arm -O linux -T script -C none -a 0 -e 0 -d cfpro-boot.script $@.bootscript
endef
+define Build/boot-scr-cfbase
+ rm -f $@.bootscript
+ mkimage -A arm -O linux -T script -C none -a 0 -e 0 -d cfbase-boot.script $@.bootscript
+endef
+
define Build/boot-img
rm -f $@.boot
mkfs.fat -C $@.boot 16384
@@ -182,6 +187,21 @@ define Device/armada-388-clearfog-pro
endef
TARGET_DEVICES += armada-388-clearfog-pro
+define Device/armada-388-clearfog-base
+ KERNEL_INSTALL := 1
+ KERNEL := dtb | kernel-bin
+ DEVICE_TITLE := SolidRun ClearFog Base
+ DEVICE_PACKAGES := \
+ kmod-nls-cp437 kmod-nls-iso8859-1 \
+ mkf2fs e2fsprogs kmod-fs-vfat kmod-fuse kmod-fs-f2fs \
+ kmod-ata-core kmod-ata-ahci kmod-ata-marvell-sata kmod-scsi-core kmod-scsi-generic \
+ kmod-button-hotplug kmod-gpio-button-hotplug
+ IMAGES := sdcard.img.gz
+ IMAGE/sdcard.img.gz := boot-scr-cfbase | boot-img | sdcard-img | gzip
+ IMAGE_NAME = $$(IMAGE_PREFIX)-$$(2)
+endef
+TARGET_DEVICES += armada-388-clearfog-base
+
define Device/globalscale-mirabox
$(Device/NAND-512K)
DEVICE_DTS := armada-370-mirabox
diff --git a/target/linux/mvebu/image/cfbase-boot.script b/target/linux/mvebu/image/cfbase-boot.script
new file mode 100644
index 0000000000..3043d261ce
--- /dev/null
+++ b/target/linux/mvebu/image/cfbase-boot.script
@@ -0,0 +1,7 @@
+setenv bootargs console=ttyS0,115200n8 root=/dev/mmcblk0p2 rootfstype=squashfs rootwait overlay=/dev/mmcblk0p3
+setenv fdt_high 0x07a12000
+
+fatload mmc 0:1 0x02000000 zImage
+fatload mmc 0:1 0x05F00000 armada-388-clearfog-base.dtb
+
+bootz 0x02000000 - 0x05F00000