summaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2023-12-18 21:22:12 +0000
committerDaniel Golle <daniel@makrotopia.org>2023-12-18 22:17:09 +0000
commit6d546b3b4cdae3ffcdad71fb6cc414f3a39bc09e (patch)
tree4cd0109ec6885c1fa2812a82394a360a6c4a5be7 /target/linux/mvebu
parent1a57d758f229a1e8d9085cd4775ebe7e1ec5d9b2 (diff)
downloadopenwrt-6d546b3b4cdae3ffcdad71fb6cc414f3a39bc09e.tar.gz
openwrt-6d546b3b4cdae3ffcdad71fb6cc414f3a39bc09e.tar.bz2
openwrt-6d546b3b4cdae3ffcdad71fb6cc414f3a39bc09e.zip
mvebu: fix RTC of IEI-World Puzzle M90x devices
The Puzzle devices come with an I2C-connected Epson RX8130 RTC. Disable the (dysfunctional) RTC units of the SoC and add driver kmod-rtc-ds1307 to support the Epson RX8130 instead. Tested-by: Thomas Huehn <thomas.huehn@hs-nordhausen.de> Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'target/linux/mvebu')
-rw-r--r--target/linux/mvebu/files/arch/arm64/boot/dts/marvell/cn9131-puzzle-m901.dts8
-rw-r--r--target/linux/mvebu/files/arch/arm64/boot/dts/marvell/cn9132-puzzle-m902.dts12
-rw-r--r--target/linux/mvebu/image/cortexa72.mk6
3 files changed, 24 insertions, 2 deletions
diff --git a/target/linux/mvebu/files/arch/arm64/boot/dts/marvell/cn9131-puzzle-m901.dts b/target/linux/mvebu/files/arch/arm64/boot/dts/marvell/cn9131-puzzle-m901.dts
index 0ad25fafbb..5bc3a846e0 100644
--- a/target/linux/mvebu/files/arch/arm64/boot/dts/marvell/cn9131-puzzle-m901.dts
+++ b/target/linux/mvebu/files/arch/arm64/boot/dts/marvell/cn9131-puzzle-m901.dts
@@ -244,6 +244,10 @@
};
};
+&cp0_rtc {
+ status = "disabled";
+};
+
&cp0_syscon0 {
cp0_pinctrl: pinctrl {
compatible = "marvell,cp115-standalone-pinctrl";
@@ -367,6 +371,10 @@
clock-frequency = <100000>;
};
+&cp1_rtc {
+ status = "disabled";
+};
+
&cp1_syscon0 {
cp1_pinctrl: pinctrl {
compatible = "marvell,cp115-standalone-pinctrl";
diff --git a/target/linux/mvebu/files/arch/arm64/boot/dts/marvell/cn9132-puzzle-m902.dts b/target/linux/mvebu/files/arch/arm64/boot/dts/marvell/cn9132-puzzle-m902.dts
index 398e53a5f9..671b592e67 100644
--- a/target/linux/mvebu/files/arch/arm64/boot/dts/marvell/cn9132-puzzle-m902.dts
+++ b/target/linux/mvebu/files/arch/arm64/boot/dts/marvell/cn9132-puzzle-m902.dts
@@ -302,6 +302,10 @@
};
};
+&cp0_rtc {
+ status = "disabled";
+};
+
&cp0_syscon0 {
cp0_pinctrl: pinctrl {
compatible = "marvell,cp115-standalone-pinctrl";
@@ -423,6 +427,10 @@
clock-frequency = <100000>;
};
+&cp1_rtc {
+ status = "disabled";
+};
+
&cp1_syscon0 {
cp1_pinctrl: pinctrl {
compatible = "marvell,cp115-standalone-pinctrl";
@@ -551,6 +559,10 @@
};
};
+&cp2_rtc {
+ status = "disabled";
+};
+
&cp2_syscon0 {
cp2_pinctrl: pinctrl {
compatible = "marvell,cp115-standalone-pinctrl";
diff --git a/target/linux/mvebu/image/cortexa72.mk b/target/linux/mvebu/image/cortexa72.mk
index 47d958b2fd..26b02e1924 100644
--- a/target/linux/mvebu/image/cortexa72.mk
+++ b/target/linux/mvebu/image/cortexa72.mk
@@ -65,16 +65,18 @@ TARGET_DEVICES += marvell_clearfog-gt-8k
define Device/iei_puzzle-m901
$(call Device/Default-arm64)
+ SOC := cn9131
DEVICE_VENDOR := iEi
DEVICE_MODEL := Puzzle-M901
- SOC := cn9131
+ DEVICE_PACKAGES += kmod-rtc-ds1307
endef
TARGET_DEVICES += iei_puzzle-m901
define Device/iei_puzzle-m902
$(call Device/Default-arm64)
+ SOC := cn9132
DEVICE_VENDOR := iEi
DEVICE_MODEL := Puzzle-M902
- SOC := cn9132
+ DEVICE_PACKAGES += kmod-rtc-ds1307
endef
TARGET_DEVICES += iei_puzzle-m902